powered by Jive Software

Transports or search feature

Hey all,

I am in a bind. Timewise and tehcnically. Here’‘s the skinny…I need to get a client up and running that has transports/gateways to AIM, MSN, yahoo, jabber/widlfire AND I need to have the excellent search capabilities of Spark or Exodus. As I was having issues (okay downright frustration) getting the transports installed on my wildfire server (linux), I was going to go the Trillan/GAIM client route that already has the transports in them. But their search features suck or are non-existent. Trillian wants to search jaber.org and I can’‘t figure out how to get it to point to my internal server. GAIM doesn’‘t even search, it just adds clients by their JID, but you have to know someone’'s JID to add them. Not efficient at all.

Does anyone know if the iq:search plugins for wildfire work with GAIM yet? Or how does anyone else search for contacts (BESIDES the JID, my users are idiots and need to search by first or last name)?

OR does anyone have any updated py* or other transport install info that might be newer than what’‘s on the ejabberd site? Any other suggestions on how to get the transports working on wildfire? For some reason when I downloaded all the python, twisted, openssl and crypto gz files, i tried to untar them and got all these error messages. I’'m not guru but I can walk around linux.

Any suggestions would be greatly appreciated.

Thanks.

PM.

Hey PM,

I checked GAIM and it seems that it does not support user searching. Have you tried using Psi? Psi supports user search and transports. Their service discovery window is pretty neat.

Useful links:

http://psi-im.org/screenshots?page=screenshots&scr=/0.9/kNIGits-browser

http://www.here.dk/jabber/psi-guide/transports/

Regards,

– Gato

Hi Gato!

I like Psi too but I need to get the transports working on my wildfire server first. Don’‘t I? I actually found out the gz files i had downloaded were corrupted or something, i went back and downloaded them all again and they installed fine. Strange how ALL 4 files were messed up. Anyway, I think i installed them alright but I’'m confused as to what I need to enter in the wildfire.xml. As to telling it what to listen for. Do you happen to have the syntax to edit the wildfire.xml file for hte transports? I have a feeling that getting the transports working is going to be easier than getting to tweak the search capabilities.

Thanks !

PM.

Hey PM,

You shouldn’'t need to modify conf/wildfire.xml to add transports to Widlfire. The config.xml file that you need to edit belongs to the Py* transport.

From the server side all you need to do is log into the admin console and click on “External Components”. Enable the service, enter the desired port and shared secret. Then make sure to use the same shared secret and port in the Py* config.xml file. Note that the JID to use for the external component has to include the server name so for instance if you server name is myserver.com then the JID of your MSN gateway has to be msn.myserver.com where msn can be anything you want.

Regards,

– Gato

Thanks Gato.

Okay, good, I was losing my mind, I thought I remembered having to do that with Jive a long time ago and thought I had to do it in wildfire. I’‘ve got the config.xml for py* all set but I’‘m not seeing it in the external components. I’'m going to run python py* -D for debug right? To see if the service is even running. I just wanted to eliminate as many factors as possible. Thank you for your help!

PM.

Hey PM,

Here are 2 useful things you can do to debug any issue.

  1. Log into the admin console and click on Sessions to see the list of connected external components to the server

  2. If no external component is there you can then enable the debug log to see the handshake process. With that info at hand you should be able to sort out any problem.

Regards,

– Gato

Thanks Gato.

I needed to install an image library and I was able to get both, AIM and MSN running. Now I’‘m off to try to get Yahoo. I have a feeling it’‘s going to be a chore. I’'ve downloaded from jabberstudios the yahoo transport.gz but now I need to know how to get it running.

Thanks for your help.

PM.

Of Course, I’‘d love to get more the ability to search my jabber server thru GAIM. If anyone knows how to do that, at least my last or first names, I’'d appreciate it.

Thanks.

PM.

I am trying figure out the same thing. In GAIM’'s buddy list window, if I go to accounts, my internal Jabber account, then search for users, it comes up with “users.jabber.org” as the location to search, if I edit that to “users.mydomain.com” and search, this is the jive server debug output:


(22:18:42) jabber: Sending (ssl):


And this is the debug output from wildifre:

2006.05.09 22:18:42 OS - Trying to connect to users.sjobeck.com:5269

Any ideas?

Does jive offer the “users” object that GAIM seems to prefer to search inside of?

Thank you.

xmpp:jason@sjobeck.com

Try putting in search[/b].example.com into the user directory dialog box. Then put */b as the search. This should return all Wildfire Jabber users. Worked for me with GAIM 2.0.0beta3 for Windows. Gleaned this information from PSI. It discovers the name automatically. I didn’'t do anything to create it in my Wildfire server configuration either. It was just there.

  • Brett

Thank you.

You know what, I just found it just now & was coming back to update my last post, and saw your post.

Yes, GAIM searches for users on the internal jive server perfectly, by searching in the location “search.sjobeck.com”.

That name is editable, I see, so if one really wanted to match, say, jabber.org, for instance, one could edit that to “users” so it looked same as searching “users.jabber.org”.

I am going to leave mine.

Cheers.

xmpp:jason@sjobeck.com

Excellent! That sounds fantastic. The only problem I’‘m having is where you enter that parameter. I can’‘t seem to find it. I’‘m using 1.5.0 so I’‘m not sure if it’‘s only in the 2.0 Beta3 version or not? Or maybe I’'m an idiot who needs more coffee. Can you guys tell me where you change that search parameter?

Thanks!

PM.

Nevermind, I downloaded 2.0.0 beta3 and answered my own question. yes, it’‘s different in 2.0.0 and what a great feature to have. That’'s perfect.

Thank you all for your info on the GAIM jabber search feature and the transport help.

PM

I know this isn’‘t really the forum for this but I’'ll try anyway, how do you make the search string permanent in that search location? Also, for an idiot user, is there an easier way to get to the user search feature?

Thanks.

PM

Looked for a way to preset the search directory name myself. Couldn’'t find one in the GAIM menus or in any of the config files. Must be hard-coded. You could download the source code for GAIM and if you can find this string, file a bug report with the devlelopers.

Personally, I don’'t like the menu layout of GAIM. Seems ad-hoc to me. I much prefer Psi. It works for AIM, MSN, etc. as long as you have the transports installed on your Wildfire Jabber server. For that, you might want to check out a couple of my previous posts. I have installed AIM & MSN running with Wildfire on Windows and SUSE Linux.

Re: Installing PyMSNT on Wildfire running Win 2K3

http://www.jivesoftware.org/community/message.jspa?messageID=120102#120102

Re: help JM start at boot suse 9.3

http://www.jivesoftware.org/community/message.jspa?messageID=105003#105003

  • Brett

Yes, it does seem a teeny tiny bit whacked to hard-code that search location in to GAIM like that, changing it every single time, every hour on the hour, seems annoying. I have posted this here:

http://tinyurl.com/q27ov

FYI.

Jason

Hi all,

I have a question about connect to pyMSN-t by client

I’'ve set pyMSN-t and Wildfire. And the session of pyMSN-t was shown in Admin Console.

However, I can’'t login into MSN in Trillian.

I’'ve set the Connection of MSN in Trillian as:

Host: localhost

Port: 5347

is that right??

But it’'s not work. And i found log here:

wildfire’'s debug log:

2006.05.11 17:13:00 Connect Socket[addr=/192.168.123.155,port=4814,localport=5347]

and there are no any log in pyMSN-t, even in Debug Mode

Why this happened??

Try putting these settings in your PyMSNt config.xml for more debug info. - Brett

[/code]

Thx bretts5964,

I’‘ve put the logging level into 3, but there are no any log info when i’'m trying to login.

However, there are some log when i trying to login Jabber (Not MSN) in Spack.

Here’'s a log:

INFO :: :: Looking for handler :: onIq :: ServerDiscovery :: {’‘el’’: <twisted.words.xish.domish.Element object at 0xb794366c>, ‘‘froj’’: <twisted.words.protocols.jabber.jid.JID instance at 0xb79433ac>, ‘‘iqType’’: u’‘get’’, ‘‘self’’: ‘‘instance’’, ‘‘fro’’: u’‘warren@192.168.123.226/Spack’’, ‘‘ulang’’: None, ‘‘to’’: u’‘msn.192.168.123.226’’, ‘‘ID’’: u’‘238O9-23’’}

INFO :: :: :: sendDiscoInfoResponse :: ServerDiscovery :: {’‘ulang’’: None, ‘‘to’’: u’‘warren@192.168.123.226/Spack’’, ‘‘jid’’: u’‘msn.192.168.123.226’’, ‘‘ID’’: u’‘238O9-23’’, ‘‘self’’: ‘‘instance’’}

INFO :: :: Looking for handler :: onIq :: ServerDiscovery :: {’‘el’’: <twisted.words.xish.domish.Element object at 0xb79436ec>, ‘‘froj’’: <twisted.words.protocols.jabber.jid.JID instance at 0xb79433ac>, ‘‘iqType’’: u’‘get’’, ‘‘self’’: ‘‘instance’’, ‘‘fro’’: u’‘warren@192.168.123.226/Spack’’, ‘‘ulang’’: None, ‘‘to’’: u’‘msn.192.168.123.226’’, ‘‘ID’’: u’‘238O9-24’’}

INFO :: :: :: sendDiscoInfoResponse :: ServerDiscovery :: {’‘ulang’’: None, ‘‘to’’: u’‘warren@192.168.123.226/Spack’’, ‘‘jid’’: u’‘msn.192.168.123.226’’, ‘‘ID’’: u’‘238O9-24’’, ‘‘self’’: ‘‘instance’’}

But i think it’'s totally not related with MSN. Why this happened??

And, am I configured something wrong so that I get login???

HELP~~~~~

If you’‘re running Wildfire on Windows, then you might want to take a look at my post to make sure PyMSNt is installed & configured correctly. (Not a perfect configuration, but it works for me). However, your configuration appears to be correct, since you’'re seeing “MSN Transport” listed on the Wildfire admin console.

Re: Installing PyMSNT on Wildfire running Win 2K3

http://www.jivesoftware.org/community/message.jspa?messageID=120102#120102

As for the client you’'re using… You said “Spack”, but did you mean “Spark”? If this is the case, then you should know that Spark does not have Jabber gateway support built in. It speaks Jabber, but only to other Jabber users, not MSN.

Also, there’‘s a difference between Trillian Basic and Pro. The Pro version supports Jabber, but it probably doesn’'t support Jabber gateways since Trillian Pro also supports client-side plugins for MSN, etc. and that would be redundant. Trillian Basic does not support Jabber at all.

So, if you’‘re trying to connect Trillian Basic, Trillian Pro or Spark, then it’'s not going to work with your MSN gateway. You need to use a client that supports Jabber AND Jabber gateways. Clients that I have used that meet these requirements are Psi, Gush and Meebo.com. These all work with Windows, Linux or Mac.

  • Brett