Trillian Pro not working and database not upgrading after 3.0 upgrade

Hi there,

My first major problem is that I don’‘t think my database isn’'t upgrading. I originally was running Wildfire 2.6.2 deployed via an RPM (on Suse 10) with a MySQL 4.1.19 database, with authentication against OpenLDAP. Earlier this week I upgraded to Wildfire 3.0.0, and am having some slight issues. Firstly in the info log in the admin console, I keep seeing “Old database found version 8… Upgrading to 10…”. Now I suspect that the upgrading is a good thing, however the problem is that this message appears every single I startup the server.

Does this possibly mean that the database isn’'t actually being upgraded? Is this normal? if not, is there any way of manually making the upgrade of the database? I suspect that there is something broken as I installed wildfire 3.0.0 from a clean install on another server to act as a warm backup, and it deployed 29 tables, whereas the actual live server only has 28 tables. The missing table is a table starts with “SASL…” (sorry I forgot the name)

I’'ve tried searching through these forums, and there are many people with questions about upgrading databases manually, and most posts point towards the document at “” but every single time I click on it, it goes to a page saying "404 There is no Action mapped for namespace / and action name entry. Check if there is such an action name with such namespace defined in the xwork.xml and also if such an action class exists. Check also the log to see if the action class is successfully loaded.

/community/entry.jspa was not found on this server."

Is there any way for me to get hold of this document? I’'ve spent about 1 hour searching the Jive site and using google with no luck. It would be greatly appreciated.

My second problem is minor: Trillian Pro doesn’‘t work with the Wildfire 3.0.0 server. It connects fine and receives messages, but you cannot send messages. Every other client it works happily and perfectly, but its just trillian pro that you can’'t send messages? I am unsure if it is just my trillian that has this problem, or is this problem occurred with my previous 2.6.2 version? Has anyone else experienced this problem?

Hopefully someone can help me

Thanks in advance,

Okay I have fixed both problems the hardway, by removing/uninstalling wildfire and the database and starting from scratch.

For some reason the upgrade scripts provided where not upgrading the database. It kept stopping on an error: about the SQL syntax being incorrect on Line 8 of the version 9 mysql upgrade script - ALTER TABLE jivePrivate MODIFY username VARCHAR(64);. I’‘m not too sure what the problem is here? I suspected it was because I’'m running mysql 4.1.19, however, after starting from scratch with a new database, and importing in the latest database, it was happy?

With regard to the Trillian problem, starting from scratch fixed it. I’'m unsure why it was doing it?

After some more investigation about the Trillian Pro problem I was having before, I found that it is definitely a Trillian Pro problem. It is fixable not by reinstalling wildfire, but why upgrading the Trillian Pro plugin with the latest one found on their website. Note that you shouldn’‘t rely on the automatic upgrade, as for some reason it doesn’'t check get the correct version. Just download the one on their website.

Hope this helps someone in future.