powered by Jive Software

Trillians Asterisk-IM support?

Matt posted this announcement:

The Jabber plugin for Trillian now has built-in support

for Asterisk-IM! Features include incoming call

notification and the ability to dial by JID or to enter

in any phone number to dial.

In the url=http://www.jivesoftware.org/asterisk-im/clients.jspclients section[/url] of the Asterisk-IM project, this has been added:

Trillian (version 3.1.2.1003 or later)

I’‘ve been trying to get this to work, but I’'m not getting anywhere. Has anyone got this to work?

I’‘ve downloaded the latests Trillian Pro (15 days trial-version), that reports back as version 3.1 Pro build 121 (how does that compare to 3.1.2.1003?). I’'ve installed it and installed the jabber plugin for it.

Now, I’‘m happily IM-ming with a co-worker over our JiveMessenger server (with Asterisk Plugin that seems to communicate with our switch ok), but I’'m unable to find any callout/voip related options in Trillian (apart from microphone settings and an empty audio tab).

What am I missing here?

On a sidenote: It takes quite long for JiveMessenger to notice whenever I go offline in Trillian. I suspect that to be a bug in Trillians Jabber plugin (not notifying a jabber server of a sign-off). Has anyone had similar experiences?

Message was edited by:

Guus

Update

I figured out the version numbering confusion. The Trillian jabber plugin[/i] is version 3.1.2.1003. I’'m still not voiping though

Update on update:

I’‘m not sure what I did, but all of a sudden, things start to work… Trillian gives me ‘‘Asterisk Phone Integration’’ as a capability, and I’‘m getting a ‘‘Enter an Extension To Call’’ textfield. It’‘s not working yet, but there’'s progress

Anyone familliar with a ''No response handler registered for internalActionId ‘’ warning?

Guus,

Not sure exactly what you need to do to make all the functionality work. For me, installing the updated plugin “just worked” with our existing Asterisk-IM install. Are you able to get call notifications?

-Matt

Guus,

First, is asterisk-im connected to asterisk manager proxy correctly. You can check this by using the asterisk manager console (asterisk -r from the command line):

apollo*CLI> show manager connected

Username IP Address

andrew 192.168.1.69

/code

If everything looks good could you post the information from phone mappings page in the Asterisk-IM tab from the admin tool. I will also need you to post your sip.conf file minus the password fields. I can use this to see if asterisk-im is configured properly.

FWIW, Trillian’'s control path for Asterisk-IM support goes more or less like:

Connect, probe for services.

If I find a ‘‘phone’’ service, try to communicate with it.

If I can communicate with it, check if my current JID has phone integration information.

It activates the ‘‘My Phone Calls’’ panel and the ‘‘Forward Call’’ or ‘‘Call User’’ options only if the phone service is present /and/ your JID is entered into the Asterisk-IM system as one of the valid users. That flow was decided on after talking to the Jive folks, because it’‘s possible to have users on an Asterisk-enabled server who don’‘t themselves have Asterisk-enabled phones and thus aren’'t in the Asterisk system.

So my gut guess would be that what changed is that your Asterisk plugin started reporting you as in the Asterisk system where before it was reporting you weren’‘t integrated. I’'m fairly sure Andrew will be able to help you sort it out further, though.

You can get at the debug XML if you need: edit your connection preferences, and turn on ‘‘Show debug XML’’ under the miscellaneous tab. That’‘ll show the XMPP stream if you view the status window for your connection, and that might also be of use to Andrew in sorting out what’'s going on.

Message was edited by:

Sparks

Thanks for all the replies. I’'ll answer them in order:

Matt, nothing of the IM-functionality works, I’'m getting no notifications either. I do get the ‘‘My Phone Calls’’ panel and ‘‘Call User’’ options as Sparks described, so Asterisk-IM gets recognised, partly at least.

Andrew, I’'m getting this:

dev*CLI> show manager connected

Username IP Address

asterisk 10.0.0.2

asterisk 10.0.0.2[/code]

I’'ve got two phone mappings in the Asterisk-IM plugin:

Username Device Extension Caller ID

frank3 SIP/frank 3333 Frank Test <1234>
guus_abc SIP/guus 2222 Guus Test <1234>[/code]

And this is sip.conf, stripped of comment and whitespaces:

[general]

context=sip

allowguest=yes

bindport=5060

bindaddr=0.0.0.0

srvlookup=no

allowexternaldomains=yes

type=friend

username=guus

fromuser=guus

callerid=Guus Test <1234>

host=dynamic

context=sip

permit=0.0.0.0/0.0.0.0

defaultip=10.0.1.108

nat=yes

type=friend

username=frank

fromuser=frank

callerid=Frank Test responseHandler not found

The IDs look like 4998186_4 incrementing by one for each attempt.

Sparks: I’‘m guessing there’‘s a bug in the logoff sequence of the plugin. If I’‘m quitting Trillian, JiveMessenger reports me as being online for quite some time after that. It’'s probably completely unrelated though.

Hi,

I’‘m working with Guus on this problem. Asterisk does appear to be picking up something from Trillian’'s Jabber plugin, because whenever I try to initiate a call using Trillian I get:

DEBUG[13509] manager.c: Manager received command ‘‘Originate’’[/code]

The fact that nothing happens as a result of the Originate command leads me to believe the problem might be in our Asterisk configuration. To test this, I tried to do an Originate command from a simple telnet session to port 5038 (manager port) as described in the voip-info.org Wiki concerning Asterisk. The commands I used (after logging in, and I am authenticated) were supposed to dial to extension 3333 (SIP/frank) while originating the call from SIP/guus:

Action: Originate

Channel: SIP/guus

Context: sip

Exten: 3333

Priority: 1

Callerid: 2222

Timeout: 30000[/code]

This results in the same message in the asterisk debug log, while the telnet session returns:

Response: Error

Message: Permission denied

Response: Error

Message: Invalid/unknown command

/code

There is absolutely no response that anything might be wrong from the Jabber plugin, though. Are these errors supposed to be forwarded, or are they simply ignored by the plugin? If the latter, at least it would make the situation from Trillian make sense.

Okay, problem solved. An administrator who shall remain nameless failed to specify the specific rights that the management channel login had. This resulted in a rejection with little to no reponse from the asterisk server. In the management channel you do get the error “Permission denied”, which might be reflected in Trillian’'s jabber plugin/Asterisk-IM in the sense of “Server responded: Permission denied, please verify Asterisk Manager configuration”.

But now everything works perfectly as it should.

Nameless

I am getting this error in the log when a call comes in from Asterisk to the configured extension:


2005.10.12 12:14:56 Unable to set property ‘‘cid-callingpres’’ on class net.sf.asterisk.manager.event.NewCallerIdEvent: no setter

2005.10.12 12:14:57 Adding text to an XML document must not be null

java.lang.IllegalArgumentException: Adding text to an XML document must not be null

2005.10.12 12:15:12 Unable to set property ‘‘callerid1’’ on class net.sf.asterisk.manager.event.LinkEvent: no setter

2005.10.12 12:15:12 Unable to set property ‘‘callerid2’’ on class net.sf.asterisk.manager.event.LinkEvent: no setter

2005.10.12 12:15:23 Unable to set property ‘‘callerid1’’ on class net.sf.asterisk.manager.event.UnlinkEvent: no setter

2005.10.12 12:15:23 Unable to set property ‘‘callerid2’’ on class net.sf.asterisk.manager.event.UnlinkEvent: no setter

2005.10.12 12:15:23 Unable to set property ‘‘cause-txt’’ on class net.sf.asterisk.manager.event.HangupEvent: no setter

2005.10.12 12:15:23 Unable to set property ‘‘cause-txt’’ on class net.sf.asterisk.manager.event.HangupEvent: no setter


Ideas? Also, I am not getting any of the options for dialing in the Trillian client, even though it is the latest with the latest Jabber plug-in installed and connected.

MuppetMaster

null