powered by Jive Software

Trying update openfire from 3.8.2 to 4.1.4

I’m trying to update openfire from 3.8.2 to 4.1.4 on Windows by exe-installer.

Db was updated from version 21 to version 25. Server running, but admin console retured error shown here:

HTTP ERROR 500

Problem accessing /index.jsp. Reason:

Server Error

Caused by:

java.lang.AbstractMethodError: javax.servlet.jsp.JspFactory.getJspApplicationContext(Ljavax/servlet/ServletCon text;)Ljavax/servlet/jsp/JspApplicationContext;

at org.jivesoftware.openfire.admin.index_jsp._jspInit(index_jsp.java:81)

at org.apache.jasper.runtime.HttpJspBase.init(HttpJspBase.java:79)

at org.eclipse.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:616)

at org.eclipse.jetty.servlet.ServletHolder.getServlet(ServletHolder.java:472)

at org.eclipse.jetty.servlet.ServletHolder.ensureInstance(ServletHolder.java:767)

at org.eclipse.jetty.servlet.ServletHolder.prepare(ServletHolder.java:752)

at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:582)

at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)

at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)

at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:22 3)

at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:11 27)

at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)

at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185 )

at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:106 1)

at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)

at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandler Collection.java:215)

at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.jav a:110)

at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)

at org.eclipse.jetty.server.Server.handle(Server.java:499)

at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)

at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)

at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)

at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635 )

at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)

at java.lang.Thread.run(Unknown Source)

What I’m doing wrong?

Are you missing the admin folder in src-> plugins ?

Directory %openfire%\plugins\admin exists

Current Openfire installer usually tries to remove older version when upgrading, but i’m not sure this works correctly when updating such old version. You can try uninstalling and wiping all folders from Openfire installation folder (make backup first), except for conf, embedded-db (if used) and resources\security and then installing 4.1.4 into same folder.

Thanks you! This really works =)