Turning off PEP service to fix memory leak

Hi All,

I understand there is a memory leak in the PEP service that may be fixed in Openfire 3.7.1. Our Openfire service keeps going down every few days due to this bug. At least, that’s what I believe. What is the PEP service and how do I turn it off?


  • Ryan

Personal Eventing Protocol

As a workaround, you can disable PEP by adding this Openfire System Property (you can add/modify properties through the Openfire Admin console):

The property xmpp.pep.enabled should be set to: false


Thanks, Daryl.