Twisted problem

I am running Windows 2003. I configured pymsnt-0.11.1 according to instructions I found in the forum and other websites.

When I try to use python I receive the follwing error

Unable to install any good reactors (kqueue, epoll, poll).

We fell back to using select. You may have scalability problems.

This reactor will not support more than 1024 connections at a time.

Could not find the XML DOM. If you’'re using Twisted 2.x make sure you have twist

ed.words installed.

Traceback (most recent call last):

File “”, line 11, in ?

import main

File “C:\pymsnt-0.11.1\src\”, line 36, in ?

import xmlconfig

File “C:\pymsnt-0.11.1\src\”, line 4, in ?

from tlib import xmlw

File “C:\pymsnt-0.11.1\src\tlib\”, line 80, in ?

from twisted.xish.domish import SuxElementStream, Element, unescapeFromXml

ImportError: No module named xish.domish

Initially I had python 2.4 installed with Twisted 2.4, then I downgraded to python 2.3 and installed 2.4 Twisted for 2.3 Python but still receive the same error. I see a Twisted folder in my Python23\Lib\site-packages\ folder along with words folder in there, so I think Python and Twisted are installed correctly. Is there something I am missing?


You should ask that type of question better in the py-transports mailinglist:

I tried posting to the mailing list, but no response. I am hoping someone have gotten transport working with Wildfire can shed some light.


johnh wrote:

Could not find the XML DOM. If you’'re using Twisted 2.x make sure you have twist

ed.words installed.

Do you installed the python XML DOM package ?

johnh wrote:

ImportError: No module named xish.domish

Try to find these package for windows.

Get the old twisted package, before they put xish into words…

The problem you are encountering is that twisted joined two projects together, and the PyTrans Guys arent on thier toes, and havent released an new edition to take that into account…

Specifically Xish was thrown into words…

Try geting Xish and installing that…

And btw when you acctually get Xish you wont be able to install it correctly, you need to copy the file from another twisted package and edit it slightly, tell me if you need help when you get there.

Message was edited by: pyrobob262

This is what I did and the installation worked:

Installed Python 2.3

Installed OpenSSL

Installed pyOpenSSL (win32 package)

Installed pyCrypto (win32 package)

Installed Twisted 2.4 or Python 2.3

Installed Python Image Library (win 32 package)

edited configuration xml file

edited windows path

in cmd


voil!. It gives error about no good reactor found, but it’'s all good (I think this only limit the number of user able to connect). from the Wildire Session\Componet Session page, it seems to work fine. Followed the last three steps for aim and works like a charm, even without the error.

I’‘m just tryign to figure out how to connect from Spark to this transport thing now. But that’'s another topic for Spark forums.

Thanks all!