Unable to access Wildfire Admin Console

I evaluated Wildfire & Spark with my laptop (XP Pro sp2) as the server. Works great. Time to go ahead and move the Wildfire server to my SBS 2K3 box…

Wildfire installation went smoothly. I was able to use wildfire_service /install and /start to get the service up and running.

I cannot access the Admin console.

I tried installing Spark on the SBS 2K3 server (just in case it was required). When initially attempting to create a new account, I got a ‘‘couldn’‘t contact server’’ error. I just tried to duplicate the error so I could show it here verbatim, but it worked. I can create accounts from Spark. I can log into Spark as admin.

I still can’'t access the admin console.

I searched this forum and found several references to the wildfire.xml config file. I am no XML expert but I have successfully modified more than a few xml files. I tried several of the recommendations but none seemed to help.


It’'d be nice to access the admin console…

Hi Tom,

do you see errors in the log files? Or that the admin console is listening on port 9090?

I hope that you did try to use the local IE and not a remote one, some guys have a 2k3 firewall enabled and wonder.

Try “netstat -an” to verify that port 9090 is not open as long as Wildfire is not running and that it is open after starting it.



I am using the local IE - not trying to admin from another machine.

I am not using ISA. Thank goodness.

I stopped the WIldfire server and ran netstat -an. No port 9090 listed anywhere.

I restarted the Wildfire server. Server window shows lots of errors now (never seen that before), but clients can still connect. Netstat -an shows IP & 9091 as LISTENING.

My error log shows lots of ‘‘java.lang.NullPointerException’’ errors along with one or two java.lang.IllegalArgumentException and java.io.IOException errors.

My warn.log file has the same error over and over:

2006.06.02 14:07:12 Closing session due to incorrect hostname in stream header. Host: Connection: org.jivesoftware.wildfire.net.SocketConnection@6ce26e socket: Socket[addr=/,port=21902,localport=5269] session: null

FYI: is the server IP.

My admin-console.log shows this error twice:

11:26:14.406 WARN!! [pool-1-thread-1] org.mortbay.util.ThreadedServer.start(ThreadedServer.java:518) >17> Failed to start: SunJsseListener1@

Even though I cannot access the admin console, I am able to install Spark on client PCs and create new accounts. The users can all talk back and forth with each other.

At this point, my big need for the admin console is to manage groups and rosters. Having every user send or receive a message from every user in order to populate their rosters is not going to go ever well with the users…


did you copy the wildifre.xml file and the database to the new server? I assume you did as something is configured, otherwise (without database) you’'d not be able to create accounts.

Did you use a domain name like “jabber.org” for your server or an IP address?

The xmpp.domain name (or the IP address) is stored in the database and should not be changed.

It could also cause trouble if one changes the conference name after creating conference rooms, it is stored in more than one location in the database.


I did not copy the database or xml file. I had only created a few accounts and figiured it’'d be safer & simpler to start fresh on the server. The db & xml on the server are straight from the windows installer.

I used the IP address, not a domain name.

Did you ever get this to work on my SBS 2003 Server I had to add the to the trusted sites on the server

Hope that helps