powered by Jive Software

Unable to connect converse.js with openfire

Hi Guys,

I have been having some issues connecting converse.js with my openfire server for the past few days. While I’ve done some in-depth research online, I still can’t manage to resolve the issue. Here’s an overview of what I have setup so far:

  • I downloaded and setup my administrator account for openfire. I also enabled http binding (for BOSH) and added both xmpp.client.processing.threads and xmpp.httpbind.worker.threads to System Properties, each with a value of 16. I didn’t change any other settings in Openfire.

  • As far as I know I have enabled the necessary ports for connection (5222, 5229, 7070 and 7443). When I run ‘sudo ufw status’ each of these ports appear with the following values: Action = ALLOW, From = Anywhere.

  • From my understanding, I need to make sure port 5222, 5229, 7070 and 7443 are open. When I run ‘nmap localhost’ only 7070 and 7443 appear to be open. I have tried opening 5222 and 5229 but running this command never seems to display them as open.

  • I have seen many conflicting solutions to editing the converse.js code (probably because a lot of the solutions are a few years old). I was afraid to change too much so the only edit I made was to bosh_service_url in dev.html which is now ‘http://localhost:7070/http-bind/’. I’m not even sure if this is the correct file to be editing.

  • I next run ‘make dist’ and then open dev.html in my browser. I attempt to login to my admin@localhost account with the password I setup in openfire, but converse just keeps saying ‘Connecting…’ but never actually connects.

I’m sure its obvious that I have very little experience with converse and openfire but I have tried so many online resources and i’m still having no luck. If anybody could offer any assistance it would be much appreciated.