Unable to connect to Embedded Database

I have recently downloaded openfire 3.6.4 to give it a trial.

Initially I tried to connect to SQL server and was unable to so added to this post (http://community.igniterealtime.org/message/183431#183431) where someone else was having the same issues.

I then tried the embeded database and it proceded to the profile settings where I tried LDAP. I was pretty certain I had everything correct but it still told me there was a problem authenticating LDAP. The error log was showing the error below.

I tried Embedded Database and Default and encountered an error setting the password. Still the error below was received

2010.12.07 12:58:09 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.jav a:92)
] Prototype
java.sql.SQLException: No suitable driver found for jdbc:hsqldb:C:\Program Files\Openfire\embedded-db\openfire
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)

The machine this is currently installed on for test and evaluation is: Windows XP SP3, 2GB RAM