powered by Jive Software

Unable to install latest packet filter plugin

I am using the latest openfire version (3.9.3) with the latest packet filter plugin (3.2.0) From the available plugin list the Green + Icon has now dissapeared but its not showing up in the install list of plugins.

When i look at the log i see the following error. Operating System Ubuntu 13.04 and jre openjdk-amd64

OpenJDK Runtime Environment (IcedTea6 1.13.4) (6b32-1.13.4-4ubuntu0.12.04.2)

OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)

2014.10.14 05:03:24 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: /usr/share/openfire/plugins/packetfilter

java.lang.UnsupportedClassVersionError: org/jivesoftware/openfire/plugin/PacketFilterPlugin : Unsupported major.minor version 51.0

The plugins delivered from the Igniterealtime server are for Java7 and higher.

you mean i have to use the SUN JRE?

I am not for certain, but just anything that is java7 compatible.

I am having this exact same problem. Were you able to get this working? I have Java7 installed on CentOS, but I am still not getting the green plus mark to install the plugin. Where you able to get this working, or does anyone know how to get this plugin to install? Thanks.

I also was having this problem, but was able to finally get it working. As stated, you have to be running Java 7 or higher. The gotcha is if you install with Java 6, reinstalling it does not seem to work. So, if you installed it with Java 6, the steps to fix it are:

  1. Upgrade Java to 7 or higher

  2. Remove the packet filter plugin

  3. Edit your database and drop the ofPfRules table

  4. Delete the version for packet filter from the ofVersion table

  5. Install packet filter

It should work after that, or it finally did for me. Hope it helps.

1 Like