powered by Jive Software

Unable to install Openfire 3.7.1 on Ubuntu 12.04


#1

I’ve installed previous versions of Openfire onto older releases of Ubuntu, but I have hit a wall this time.

I dealt with the fact that JRE6 was unavailable by following the instructions at https://sites.google.com/site/installationubuntu/tweaking-ubuntu/reinstall-sun-j ave-in-ubuntu to install update-sun-jre

Then when I run:

sudo dpkg -i openfire_3.7.1_all.deb

I see:

adduser: Warning: The home directory `/var/lib/openfire’ does not belong to the user you are currently creating.

I tried:

sudo chown -R openfire.openfire /var/lib/openfire

but it didn’t seem to help.

Running:

sudo dpkg -i openfire_3.7.1_all.deb

again didn’t help either.

If I run:

sudo /etc/init.d/openfire status

nothing is returned

Looking at the prerequisites for Openfire I saw no mention of Apache so I did not install it, is it required?

Does anyone have any suggestions as to a fix?

Thanks


#2

Apache is not required.

Do you have java installed? Is the command ‘java’ recognized?

Does you have check for /var/log/openfire/error*.log?

Check this:

** [SOLVED] Install openfire 3.7,1 on ubuntu server 12.04 64 bit**

http://ubuntuforums.org/showthread.php?t=1970353


#3

java is recognized. It shows me a bunch of options when I type that.

/var/log/openfire is empty.

I was atually following that thread and doing a reinstall when your response hit, but I got stuck again with this error:

Downloading jdk-6u32-linux-i586.bin : failed

talks about how it can be fixed and I ended up modifying the shell script to point to http://www.oracle.com/technetwork/java/javase/downloads/jre6-downloads-1637595.h tml but that didn’t work either.

Frustrating :-/

Thanks for the response


#4

As stated in download page:

openfire_3.7.1_all.deb "Debian package, no Java JRE… "

It is for Debian not for “Debian like” systems, so it probably doesn’t work on Ubuntu systems at all.

I have an openfire 3.7.1 working on Ubuntu 12.04 using the unix tar.gz package:

openfire_3_7_1.tar.gz “Works on most Unix variants, no Java JRE…”

It includes a “documentation/install-guide.html” with the package (please read it)

I’m going to resume the installation procedure I made (See result in screenshot):

  1. Download and make a fresh installed Ubuntu 12.04 Desktop Edition for 32 bits.

  2. Download and install jre-6u33-linux-i586.bin (jdk is not need just jre):

Get it here (or google for it):

http://www.oracle.com/technetwork/java/javase/downloads/index.html

Then set it up:

chmod +x jre-6u33-linux-i586.bin

./jre-6u33-linux-i586.bin

mv jre1.6.0_33 /opt

  1. Download and install openfire openfire_3_7_1.tar.gz

tar xvfz openfire_3_7_1.tar.gz

mv openfire /opt

Go to the openfire folder and continue with the rest:

cd /opt/openfire/bin

Uncomment and modify the following line at the beginning of “/opt/openfire/bin/openfire” script to override “JAVA_HOME”:

INSTALL4J_JAVA_HOME_OVERRIDE=/opt/jre1.6.0_33

WARNING: This is not need if “echo $JAVA_HOME” point to a valid ORACLE Java 1.5 (or later) or OPENJDK installation path. Openfire does not works with “gcj” which can be installed on Ubuntu, check installed version executing “java -version”.

Then just start it!

./openfire start


#5

Perfect.

Thanks for the pointers.


#6

Hello,

I’ve just successfully launched OpenFire 3.7.1 on LinuxMint 13, so I guess it should work on Ubuntu 12.04, 12.10 too.

First of all I’ve installed Oracle Java 7

  1. sudo apt-get purge openjdk*

  2. sudo add-apt-repository ppa:webupd8team/java

  3. sudo apt-get update

  4. sudo apt-get install oracle-java7-installer

Then downloaded and installed openfire_3.7.1_all.deb

Ofcourse when I tried

sudo /etc/init.d/openfire start

sudo /etc/init.d/openfire stop

sudo /etc/init.d/openfire status

nothing was happening

so I’ve

sudo gedit /etc/init.d/openfire

and added line:

t=/usr/lib/jvm/java-7-oracle && test -d $t && JAVA_HOME=$t

right here:

if [ -z $JAVA_HOME ]

then

t=/usr/lib/jvm/java-1.5.0-sun && test -d $t && JAVA_HOME=$t

t=/usr/lib/jvm/java-6-sun && test -d $t && JAVA_HOME=$t

t=/usr/lib/jvm/java-7-oracle && test -d $t && JAVA_HOME=$t

fi

and it started to work like it should!

Hope this helps.