powered by Jive Software

Unable to log in to Openfire

Guys, I really need some help! I’m a complete newbie to openfire and am starting to go around in circles. I installed Openfire 3.6.4. on Windows 7 (64-bit) and am using the embedded-db. The problem I’m having is no mater what I try I cannot log in! I’ve reinstalled it to no avail.I can configure the server fine but after configuration it won’t let me log in. I’ve even tried updating the openfire.xml fire as suggested in this post:

http://www.igniterealtime.org/community/thread/35034

Add:

joe

After modifying the file, stopping, and starting Openfire, the server restarts fine, however when I try to submit the login form something strips out the line joe. I’ve also noticed change to on a couple of occassions.

Any help would be greatly appreciated? I’ve attached a few files that might help with troubleshooting.
openfire.script.zip (2600 Bytes)
openfire.xml (1287 Bytes)
error.log.zip (5988 Bytes)
info.log.zip (2496 Bytes)
warn.log.zip (731 Bytes)

Forgot to mention this, the username and password seem to be valid as I’m not getting the following error:

Login failed: make sure your username and password are correct and that you’re an admin or moderator." or add

Neither is the warn.log file updating with a warning about a “Failed admin console login attempt”. The only change I see when I log in is the URL change from:

http://localhost:9090/login.jsp

to:

http://localhost:9090/login.jsp?url=%2Findex.jsp

I’ve tried changing the URL to http://localhost:9090/index.jsp but it keeps changing it back to http://localhost:9090/login.jsp?url=%2Findex.jsp.

On the home page there is an announcement about that that says to stop the service and restart it 2 times. I had the same problem initially, i used admin and admin for user and pass and it got me in.

Thanks Stephen - althought I’ve tried restarting it loads of time.

Have you deleted your openfire database and started with a new one? Also is the openfire service running?

The service was running but there must have been something wrong with the database. I had tried uninstalling and reinstalling but hadn’t verified whether that had deleted the old database or not.

In case anyone else has the same issue, I renamed the ‘embedded-db’ folder to ‘embedded-db-old’ and changed the ‘setup’ parameter (conf\openfire.xml) to false:

Was:

true

Modified to:

false

I then restarted the service and ran through the set-up again. After it completed I restarted the service a couple of times and it’s now working fine for me.

I honestly think that most people are just not waiting long enough for the setup to finish configuring the database before logging in. I do realize it takes you to the login page but the system needs to finish the setup processes. This has been the case since the data was moved from the XML file to the database.

Hello,

I honestly think that the documentation must mention this situation. I was fighting with that simple and singular issue for 2 days until I´ve found this.

What about an update on the installation guide?

Thanks for the tip. It now works for me.

Regards!