Unable to login from Spark after upgrading Openfire to 3.10.0


I had Openfire 3.9 with it’s embedded database. I use Spark (2.6.3) for chat client. I just updated openfire 3.10.0 and followed all instructions given in the update guide. During update it asked me to overwrite plugins and I clicked Yes. After upgrade I am unable to login using Spark messenger. Login is attempted by spark and it gives error as “Invalid username or password”. I am able to login from web (http://my-server:9090) using my login id and password. Everything was working fine before upgrade.

I am not sure what has gone wrong. Please help me to get over this issue as my whole communication channel has broken down. I have a backup of Openfire 3.9.

try the Spark update first, rss most probably not related (from another thread):

RSS not working is a known problem (after switching to https on the site) https://igniterealtime.org/issues/browse/OF-798

And now i think, could it be related

you can try first disabling RSS, by adding a system property rss.enabled with a value false

then restart Openfire and see if it helps, though i doubt

I think the most probable thing causing login failure with SSL/TLS is the built-in Java update in Openfire 3.10.0 (bumped to 1.7.0_79). You can try a few things. Updating Spark to the latest 2.7.0 build http://bamboo.igniterealtime.org/artifact/SPARK-INSTALL4J/shared/build-669/Insta ll4j/spark_2_7_0_669.exe

Or you can try copying old jre folder form Openfire 3.9.3 (or Spark 2.6.3) into Openfire 3.10.0 installation folder (first delete current jre folder in there).

1 Like

Hi Wroot,

Installing Spark 2_7_0_660 worked great. Everyone is now able to login to openfire server after upgrading to the Spark messenger release you have given.

Thanks a ton for your quick help and support.

However I first tried replacing jre folder but it didn’t work. I though of sharing this information so that other people reading this post don’t invest time for this task.

Thanks again.



have a try

johnson, this workaround is not suitable for everyone, especially on public networks as it is less secure.

Premal, thanks for the info. Strange that jre replacemnt didn’t work. Will still test it later myself. But i think using latest Spark is still beneficial because of many fixes and some new features

Hi Wroot,

I have installed openfire as windows service. When I replaced jre folder I could not start openfire service. So I copied original jre folder and I was able to start the service.

Yeah, my first thought was that Spark 2.6.3 couldn’t login, because Java in Openfire 3.10.0 has been updated to 1.7.0_79 (was 1.7.0_50 a few years old). I thought maybe new Java had some security changes. But maybe it’s not the case. It can be that in Openfire 3.10.0 something has been changed in the SSL connection negotiation part. As Spark 2.7.0 uses newer Smack library, it worked fine. But i’m not 100% sure on the exact cause.

Well, at least it made us push the 2.7.0 release out of the gate

Hi wroot,

I am also facing problem with ofmeet plugin for openfire. My main intension of upgrading openfire to 3.10 was to get benifit of ofmeet plugin for screen sharing which only works with Openfire 3.10 version. After upgrade I installed ofmeet and fast path service plugins and openfire meetings extension for google chrome browser.

When I access ofmeet URL and create new room https://my-server:7443/ofmeet/?r=Room it shows me all menu options but when I click on Share button it doesn’t create share link and the window halts at message **“Your conference is currently being created.” **Also no meetings get created under openfire web console under Meetings section. I have raised this question under openfire-meetings section but no reply so far.

Can you please suggest a solution if you have experienced same issue or let me know if anyone has successfully configured ofmeet plugin under windows? Or direct me the relevant people or group?

Can’t help with that. I’m not using ofmeet and haven’t ever tried to setup it. I can only suggest to post your question in openfire-meetings forum and maybe Dele (the author of this plugin) will answer it.

1 Like

Thank you.