powered by Jive Software

Unable to login to Administration Console and Spark connects fine

I have installed Openfire 3.4.4 on a Windows Server 2003 sp1 server and the Spark client. I ran through the Openfire setup and created a database connection to a sql database and connected to our AD. These tests succeeded in setting this up. Now that I am done with that, I can’t connect to the Administration Console but can connect the Spark client using AD accounts. I tried adding a userid to the jive.Users table in the SQL database, but that didn’t work. Any suggestions?

Is the ID your attempting to use to access the server in the openfire.xml file. The AD user you are trying to use to access the admin site must be located within your BaseDN, and must be in the openfire.xml within this tag: <authorizedUsernames>johndoe</authorizedUsernames>

Yes, it is in that file as well as the admin userid.

Is the user you are attempting to use within your BaseDN you set in openfire?

Yes, the account is in an OU under the BaseDN OU that I have specified. I even tried setting it to the exact location (OU) that that user is contained in. Has anyone ever been able to use AD for authentication of IM Client and the Admin Console? It looks to me like it is one or the other, and once you enable the AD authentication it disables the admin account.

I have attached a screenshot of the error I receive when trying to login into the admin console. I reran the setup by setting the config file to false and used an embedded database and no connectivity to AD. It was a default setup and it still would not allow me to connect. Any suggestions?

I just finished an install on a 2003 R2 64 Bit server and I"m seeing the EXACT same thing you are. I can log in with a client, and xml file contains the correct names, but I can not log into the admin console. I actually put in 3 accounts in my admins, and none of them work.

Any progress on yours?

I tried logging into the admin console from a machine that wasn’t runninig the server, and it worked.

I still can’t log in from the local machine. Is this intended behavior?

I am still unable to login, even from a different machine. Is there anyway I could get a copy of your config file to compare to mine?

The XML file?

I figured out that the userid is not case sensitive…you have to enter the userid in all lowercase letters or else it will not work. I am able to login remotely and on the server now. I noticed that you need to quit out of the openfire server and open it back up for the settings to fully apply. Thanks for the help everyone!

Nice catch.