powered by Jive Software

Unable to login to SparkWeb

I am running Openfire 3.3.3 Enterprise Trial.

When I try to login to the server using Sparkweb, I get two error messages after inputting my credentials:

{getText(‘message.unable.to.login’)}[/code]

and

there was a security error of type: securityError

Error: Error #2048

/code

What’s the problem here?

Thanks

This is related to the crossdomain.xml file used by Flash; It should be fixed in the upcoming non-beta version of SparkWeb.

I encounter this issue on Openfire Enterprise 3.4.1

I can confirm that I’m still getting the security error with Openfire 3.4.1 Enterprise

Hmm… this could be due to a firewall blocking access to crossdomain.xml. You’ll need to make sure port 5229 is open.

No firewall between me and the server.

Please tell me how the browser/flash app attempts to access this file… what domain, url, etc.

When you attempt to login, it will access xmlsocket://theurlyouspecified:5229

The enterprise plugin listens on that port, and returns a crossdomain file that should allow access. Apparently something isn’t working there; I will investigate.

where do you determine “theurlyouspecified” from?

The ‘server’ field on the login dialog.

ok… that’s the reason.

We have our server thinking it’s just “domain.com” so that all of the users can login using their email address, instead of user@chat.domain.com. However we access our server via chat.domain.com.

When I go to the sparkweb login page, the server field is prefilled with domain.com. When I changed this to chat.domain.com, it worked perfectly.

Perhaps sparkweb can be coded to use the web browsers URL instead, or some other magic? We access sparkweb on our browser via http://chat.domain.com:9090/plugins/enterprise/sparkweb/index.jsp

I opened that port on the server’s IPTables list, and it works now.

Thanks

or perhaps there’s a way I can change what the sparkweb login form will prepopulate with?

One of the things I’m hoping to add for the next version (tons of stuff already on the list, so no promises) is better admin-side configuration of what to show, what to prefill, etc…

I’ll think about what to do about this issue; one of the fixes made late in the beta process is that once logged in, sparkweb will use the server’s domain name even if it’s different from the domain used to log in (so even if you logged in with the server’s ip address, you’d still be listed as name@domain). This is somewhat different from that though… perhaps I could check a couple of different options to see which one(s) have a crossdomain with the right settings available.