powered by Jive Software

Unable to login with encryption

Hello all

I just installed Openfire on Ubuntu Dapper 6.06 and I’'m unable to login using encryption.

I’'m testing with Pidgin (aka, gaim) and I receive the error:

The server requires plaintext authentication over an unencrypted connection. Allow this and continue authentication?

I’‘ve tried enabling the “Force old (port 5223) SSL” option but this doesn’'t seem to help either.

In the admin console, I’‘ve set Client Connection Security to Required. I’'m using the default SSL keys.

Does anybody have any suggestions?

First of all, this has nothing to do with SSL/TLS. Password encryption is deprecated (see XEP-0078)

Which Openfire-Version are you using? At the begin of this year (?) we had the same problem, but the bug was solved in one of the newer versions. You should use the current Openfire-Version.

Coolcat

Sorry, I tried to edit my post but I guess I didn’'t save it.

I wasn’'t specifying the server to connect to in my client, so it was actually connecting to an existing jabberd server. I jumped the gun a little, sorry for that.