Unable to start admin consonle on first install

Urgent request from a charity

There seems to be a common problem of not being able to log into to the admin consule on first instalattion.

I have stopped and restarted the server many times and changes the configuration from embedded database to MYSQL nothing works.

I have also changed permission on various directories - no change.

I can see that the MySQL user table ‘toUser’ is being updated when I change the password on the setup pages. But nothing allows me to log into the admin console.

I have seen this problem on many sites and in this forrum but nobody seems to be able to come up with a resason.

I do not have time to trawl through the code to find where it is exactly failing so can someone please please advise.


Login failed: make sure your username and password are correct and that you’re an admin or moderator.

What username do you try to login with? What OS are you on? If it’s Windows, are you using launcher or maybe a service?

I have the same problem… i have ubuntu 8.04 Desktop LTS. Embbed BD.

Same Issue here.

I’ve installed opensfire on a openSUSE box. I tried both database (mysql and embeded) options and it continues saying that user and password are wrong.

I’ve cheked the data base and everything is fine.

I tried reinstalling everything from scratch and skipping the step for setting up a new password and it leaves the default password there… and it does not accept it.

Check picture please.

I remember having the same problem and I think I fixed it by modifying the **setup **value in openfire.xml (/opt/openfire/conf/openfire.xml) from true to false and then restarted the daemon.

Also try using admin/admin and not the password you have set during the setup process.

I just had this same exact problem yesterday. I’m running it on Windows, but i don’t think that matters. Here’s what worked for me.

  1. Do a complete uninstall

  2. Wipe out the openfire folder under Program Files (if windows) or equivalent as their uninstall does NOT do a complete uninstall as they advertise, or at least, not for windows

  3. Reinstall Openfire, and when you see it running, do not launch the admin but instead reboot the OS (not just the database).

  4. After reboot, relaunch openfire. then, when it’s started, launch the admin and it will go into setup. Finish set up, but ignore the button to log on to the admin after the setup has been finished and instead, reboot once again. Then, upon reboot, start openfire again, then launch the admin and then you should be able to log in. This is apparently some sort of openfire bug that doesn’t occur if you use something like active directory to manage users and instead use openfire’s built in database. Somehow, it needs a reboot to stick, whereas if you use ldap or an existing user management system rather than openfir’e’s own, it doesn’t. I wish they would tell us why, but since this a free product, documention is very limited.

Bobh wrote:

This is apparently some sort of openfire bug
Yes. It was filed and fixed in 3.6.5 code long ago. Personally, i think 3.6.5 could be released just because of that fix. But we are not in release control yet. So we wait for Jive to do this.


I encountered it on Windows with the embedded DB, and I suspect that a lot of people are going to encounter this bug, since the demo of Google Wave protocol (just released) uses Openfire


3.6.3 and this doesn’t seem to have the problem.

I suggest that anyone who knows anyone puts some pressure on to get the new version out asap…

Wow I have just watched the Google Wave demo few days ago and was thinking how useful this could be in our organization and how complex it can be to setup your own version. It seems it could be easier than i thought, as we already have Openfire

I suggest that anyone who knows anyone puts some pressure on to get the new version out asap…

Anyone can drop an email to matt jivesoftware com and try to push them to make a release or to push the process of giving release tools and rights to the community.

Why not point out use “admin” as user name rather than the admin email address in the documentation???

(message moderated)

What part of the documentation points to use email address? One should read carefully.openfire_admin_username.jpg

Also, swearing is not tolerated in this community.