powered by Jive Software

Unable to start Meeting with ofmeet

Hi,

I have openfire 4.1.5 running on CentOS (which is behind a Firewall and is NATted to a public IP). My folks use Spark & Jitsi mainly for text based chatting. I have downloaded the appropriate plugins for OpenFire Meetings (0.9.2) and I am able to see the OpenFire Meeting base page. However, when I attempt to create a room and enter it via chrome (Version 60.0.3112.101), I get the error message "connection.OtherError". I have allowed the microphone and camera access from the browser.

Additionally, I have configured the min and max ports for Meetings as 5000 & 5100 respectively. The same are open in the Firewall as well (TCP & UDP) as well the Host system OpenFire is running on.

Since I’ve integrated OpenFire with my client’s Active Directory, I have also created the user “focus” and updated the password for the same under Settings in the Meetings.

My logs don’t show up anything strange or related to Meetings or otherwise. I’m stumped as to where to start investigating. I’d appreciate any help in resolving this.

I started investigating a bit more and found the error to occur when the websocket conection is established. To be more precise…

strophe.js:5195 WebSocket connection to ‘wss://openfire.**********.com:7443/ws?room=bigheartdudesfail’ failed: Error during WebSocket handshake: Unexpected response code: 302

Digging around more, I found that I have the latest OpenFire WebSocket plugin installed - deleted it and re-installed it again with no change in the result. The http binding configuration is also set properly.

Curiously, the ofmeet kinda worked with the previous version (0.9.1). Not sure what is broken now.

Attaching screenshot of the error from Chrome developer console. Any help is appreciated!

same issue, any ideas how to fix?

Nope. But I’m sure it has to do with either of the three below since there were updated recently…

  • Openfire Websocket

  • Openfire Meetings

  • Openfire

Searching on the issue itself hasn’t been much helpful either.

Same issue after update to the latest version. Any ideas how to fix. Openfire is running on a Windows Server 2016 Standard.

Hi, do you remember the version numbers of each openfire plugin related to ofmeet that you had working? I can install a full test system to verify if that’s the problem.

I’ve just tried with the latest versions and I have the exact symptoms you decribe.

Thanks

Sure…

OpenFire Meetings - 0.9.1

OpenFire Focus Provider - 0.9.1

OpenFire WebSocket - 1.2.0

OpenFire - 4.1.4

Thanks! I’ll try to get those versions and make a lab with them. I’ll keep you posted

Well, I’ve managed to get those versions, but when I try to install any plugin, they don’t show in the console. I can’t go further.

I’m using Suse SLES 11.3 x64

You can install the plugin directly from the server. Navigate to openfire’s installation directory on your server and look for the directory called ‘plugins’.

Then use the curl command to download the plugin directly to that directly. Once done, just restart the openfire service and the plugins should be installed. If the service fails, just restart it again and it should be fixed.

Let me know if this succeeds.

Yep, I’ve tried copying the plugins to the plugins folder, the server automatically creates the corresponding folders, as if they were installed, but they don’t show in the admin console thus I can’t configure them.

I’ve restarted the server but it didn’t help either.

Could be the operating system version? It’s a fresh install.

Do a tail on the log file all.log under logs in the openfire installation directory. Access the plugins option and let me know if you observe any errors.

Ideally, like you said, after the plugins are installed, they should come up in the plugins directory. If possible, can you post a screenshot of the web console?

Oh My…thanks to your help I think what’s happening, the plugins I’ve downloaded are not for this server version, at least one of them.

Can you please point me to the right download place? I thought I was downloading the 4.1.4 version but no. Thanks.

This is what the log says:


at org.eclipse.jetty.server.Server.handle(Server.java:499)

at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)

at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)

at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)

at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635 )

at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)

at java.lang.Thread.run(Thread.java:748)

2017.09.20 10:55:28 WARN [pool-1-thread-1]: org.jivesoftware.openfire.container.PluginManager - No plugin loader found for ‘offocus’.

2017.09.20 10:55:31 WARN [pool-174-thread-1]: org.jivesoftware.openfire.container.PluginManager - Ignoring plugin ‘offocus’: requires server version 4.1.5. Current server version is 4.1.4.

For ofmeet and offocus --> https://github.com/igniterealtime/ofmeet-openfire-plugin/releases

For websocket --> https://igniterealtime.org/repo/org/igniterealtime/openfire/plugins/websocket/1. 2.0/

Well, I thought I’d made a mistake, so I reinstalled everything, and to my surprise, neither the 0.91, 0.90 or 0.92 versions work. Could something be messed up with the download site? See my logs:

2017.09.20 14:36:04 WARN [pool-3-thread-1]: org.jivesoftware.openfire.container.PluginManager - No plugin loader found for ‘ofmeet’.

2017.09.20 14:36:07 WARN [pool-24-thread-1]: org.jivesoftware.openfire.container.PluginManager - Ignoring plugin ‘ofmeet’: requires server version 4.1.5. Current server version is 4.1.4.

2017.09.20 14:46:22 WARN [pool-56-thread-1]: org.jivesoftware.openfire.container.PluginManager - Ignoring plugin ‘offocus’: requires server version 4.2.0 Alpha. Current server version is 4.1.4.

2017.09.20 14:50:53 WARN [pool-3-thread-1]: org.jivesoftware.openfire.container.PluginManager - No plugin loader found for ‘offocus’.

2017.09.20 14:50:55 WARN [pool-71-thread-1]: org.jivesoftware.openfire.container.PluginManager - Ignoring plugin ‘offocus’: requires server version 4.1.5. Current server version is 4.1.4.

0.9.1 (and probably also 0.9.0) had requirement of 4.1.5. Not sure how Mohan manages to run them with 4.1.4. Only the older version 0.3.29 had 4.0.1 as min server version.

Uploaded 0.3.29 here https://www.sendspace.com/file/lk0n26

Thanks wroot!

I’d like to install the latest stable version of Openfire+ofmeet and extra necessary plugins. Can you point me to a full working versions of components?

I’m having the odd message ‘connection.OtherError’

Thanks!

I can’t help with that as i don’t use ofmeet myself.

I believe I used the older version (0.3.29) and not 0.9.1
Not sure If I can confirm that either.