Unable to start openfire as service in linux

hi guys i am totally new to linux and i am trying to install openfire into a xandros machine.

I installed openfire_3_5_0.tar.gz successfully and everything works well, except i have no idea how to set openfire as a service. I’ve tried to follow the documentation but had no luck. i don’t know what went wrong and don’t know what to do as my knowledge on linux is very limited…

So i hope that someone can show me some guide on this, thank you.


the RPM installer should setup also the rc scripts that Openfire start automatically after a reboot.

You should find some scripts in the bin/extra directory to do this using the tar.gz version.

Anyway if you use the Openfire start script Openfire is started in the background as a daemon.


I have not used Xandros before, but it looks like it’s init scripts are in /etc/init.d

Found a forum post from the xandros site that said a gui config is availabe at

Control Center -> System Administration -> Services

See also this thread:

hi thanks for replying.

i couldn’t install with the RPM or deb installer because both gave me

some error message, so i have no choice but to use the tar.gz version.

i did copy the openfired script inside bin/extra to /etc/init.d and follow the instruction inside, but still no luck

i was unable to locate Control Center -> System Administration -> Services

If Im not mistaken, Xandros is based off Debian…

"Xandros 3 is based on a snapshot of the “Sarge” (currently “stable”) release of Debian. " found that in the forum. So the deb package should do the trick. However all distros usually have you go through a package manager(the application you use to download and install/remove programs*). Do you know if your Xandros is based off KDE? If it is and you know how to use your package manager. You can locate a program called “KPackage”. Its an installer/package manager that allows you to install .deb & .rpm type packages that are outside your linux’s repositories.