Update notification

Hello,

my openfire installation keeps bugging me that there is an update available,

pointing me to the 3.6.0a release.

But:

[marcus ~]$ rpm -qi openfire
Name : openfire Relocations: (not relocatable)
Version : 3.6.0a Vendor: Jive Software

Ive got the latest’n’greatest release installed.

During the installation process I had this mysql4 varchar size problem,

maybe the server does not recognize itself being the a release because

of this?

Looking at the admin webinterface i see:

Version: Openfire 3.6.0

Can I tweak the database somehow or should I perform another install

of the rpm to make this daily notification go away?

I found a table named ofVersion in the database, but I do not fully understand

the values

mysql> select * from ofVersion;
±--------------±--------+
| name | version |
±--------------±--------+
| openfire | 20 |
| clientcontrol | 0 |
| monitoring | 0 |
±--------------±--------+

Is 20 the value for the 3.6.0 release and 21 for the 3.6.0a?

regards,

Marcus

You can ignore that message in admin console. Openfire does not support the “a” in the version string.

Ok,

but why do I keep getting these “There is an update available: 3.6.0a” messages?

I general, I like this message, as I do not have to look at the project page every

other day if there is something new. But this one is rather annoying, as I have

the latest release already.

regards,

Marcus

but why do I keep getting these “There is an update available: 3.6.0a” messages?
Because 3.6.0a thinks it is 3.6.0.

Erm,

thank you, thats what the server is sending me reminds for 53 days now.

Every day I get this message and everyone else in the admin group.

Id like to make this message go away and never ever to return in this way.

Or do you try to tell me, that every 3.6.0a installation out there keeps anouncing

to their admins this rather silly message? Honestly I do not believe the software

being that braindamaged.

regards,

Marcus

Yes the software is that flawed. The update notification mech does not support letters in the version. This means that it will always view the 3.6.0a file as a new upgrade even if you installed it. Everyuser in the world using openfire 3.6.0a with notifications enabled will have this problem.

Ouch,

ok, am lost of words…

Let me rephrase my question, is there a setting to turn off notifications

in general?

I had a look into the settings, but there is no key, that sounds like it

would turn them off. Do I have to create a new key?

regards,

Marcus

is there a setting to turn off notifications in general?
yes…Server settings -> Manage Updates ->Admins Notifications

However, this “Update information” banner on start page will stay.

You can disable admin notifications for now. Until 3.6.1 is released. 3.6.0a was a quickfix for 3.6.0 release and it doesnt contain any fixes planned for 3.6.1. So it’s not really a release and can’t be named 3.6.1. Though it does create some annoyance. We should wait for the next release. But we cant tell you any exact date as there is currently no active official developers working on Openfire, as far as i know.

Ah,

Found it. Silence for a while

Many thanks for the help!

Marcus