Upgrade from 3.9.3 to 3.10.3 Ubuntu 12.04

Hello all,

I have been running openfire for some time now. I would like to upgrade to 3.10.3 from 3.9.3. I am using Ubuntuy 12.04. Every time I try upgrade to the new version… Openfire never starts up. I have tried removing all the plugins and then upgrading. I am not sure what I am missing… but I am missing something in the steps. I am using the .deb package and just downloading it via wget through cli and using dpk to install. Any ideas on where I should look would be greatly apperciated.



Lots of things could be wrong. Check under your installation directory: openfire/logs for the file error.log. Unless we know what your error(s) are/were, we can’t give you a good answer.

I cleared out the error.log file and then upgraded… it doesn’t seem to update the error.log file… is there a way to start it from the command line so I can see the errors when it tries to start?

ok… i will answer my own question… got it started on the command line by using this command from the /usr/share/openfire/lib directory

java -classpath startup.jar -jar startup.jar

and it worked fine… so it must be a java issue with how the init.d script is set up… i know the script used java6… i thought I changed it to use 7 but maybe I did it wrong the first time… I will update later when/if I get it figured out

Some installations create a startup service script under /etc/init.d. Mine is called openfired. Login as root, then:

cd /etc/init.d

./openfired start

(make sure you have the period slash before the openfired, to tell it to run from the current directory). Besides

start, the other commands for the script would be status, stop and restart. If that script is not available, you

would have to cd to the openfire/bin directory and run the openfirectl script with the same parameters. You

would also want to be sure that your java version is up to date and matches the directory/location that is in

either script that you use.

  • David

You should do:

which java

to find out what directory it is being run from, then:

java -version

to find out which version you are running. Look into the /etc/init.d script, or the openfirectl script that I mentioned in

my last reply to find out where the java is being run from.

thanks for you help… it turned out the default java being use was the oracle v8… so I changed the init.d script for openfire to reference that version instead of v6 and the server was up and running. Thanks for helping me through this upgrade I do appreciate it.