powered by Jive Software

Upgrade Openfire 3.6.4 to 3.7 on Ubuntu

How does one upgrade Openfire 3.6.4 to 3.7.0 on Ubuntu. I installed it using .deb file. I’m not sure what files should be upgraded. Can someone point out to the location of those files.

I am also eager to find some documentation on upgrade procedure for debian like systems (In my case ubuntu 10.04 64bit).

If someone did it successfuly please share the console commands here. Thanx!

Plus 1 on this.

Just installing 3.7.0 with dpk -i on top of 3.6.4 tells me:

Preparing to replace openfire 3.6.4 (using openfire_3.7.0_all.deb) …

Stopping openfire: openfire.

Unpacking replacement openfire …

Setting up openfire (3.7.0) …

update-rc-d: warning: /etc/init.d/openfire missing LSB information

update-rc.d: see <http://wiki.debian.org/LSBInitScripts>

Starting openfire: openfire.

Processing triggers for ureadahead …

Afterwards, openfire starts but the admin website is empty and users are not able to connect.

I can not see any errors in any of the files below /var/log/openfire/

haecker wrote:

Afterwards, openfire starts but the admin website is empty and users are not able to connect.

I can not see any errors in any of the files below /var/log/openfire/

I had to delete the old plugins from /var/lib/openfire/plugins and restart OpenFire. Then I could reinstall them via the web interface and everything worked again.

The only problem I have now is MSN via Kraken not showing online status of MSN contacts and that OF seems to not find some other Jabber servers (shows “404: Remote host not found”).

UPDATE: As I did the upgrade today on an Ubuntu Server, here’s what I did:

  1. download the .deb Package of OpenFire 3.7.0
  2. stop the running OpenFire: sudo /etc/init.d/openfire stop didn’t work, so I had to find the PID and use kill
  3. delete all plugins (NOT their data directories): sudo rm /var/lib/openfire/plugins/*.jar
  4. update the old OpenFire using dpkg with the following command: sudo dpkg -i openfire_3.7.0_all.deb
  5. if it’s not already running, start it again: sudo /etc/init.d/openfire start
  6. wait half a minute and get into the admin interface to re-install the plugins you had, the settings will be retained (if you use Kraken, make sure to use the latest beta 3)
  7. go to Security Settings and make the checkmark at* “Accept self-signed certificates. Server dialback over TLS is now available.”*

And you should be set.*
*

1 Like

Maybe it is possible (easier) do uninstall and do a fresh install. I’m doing this with tar.gz version all the time. Just deleting everything, extracting new files and then copying settings (and db if using internal one) over the extracted copy. Also you can save /resources/security to save you certs. Plugins can be installed via admin console again.

Just stop the openfire and run sudo dpkg -i openfire*.deb

After that start openfire again.

Thanks for this hint. I followed your instructions and it worked.

To be safe, I tried this method which worked perfectly.

The only difference is that I was able to stop the server without needing to kill the process.