powered by Jive Software

Upgrade problems again (this time 3.3.1 -> 3.3.2)

I am having the same issues upgrading the RPM as I had with 3.3.0 -> 3.3.1, except this time I can’‘t fix it. I installed the RPM, and (as usual) it changed ownership of the entire directory to daemon:daemon, I chown’'d it back to openfire:openfire, the user I run it as, but I still get the

Home not found. Define system property “openfireHome” or create and add the openfire_init.xml file to the classpath

which results in this in nohup.out etc.

java.io.FileNotFoundException: XML properties file does not exist: openfire.xml

at org.jivesoftware.util.XMLProperties.(XMLProperties.java:61)

The file is there. Here is the command it runs to start, you can see openfireHome is there too

/usr/java/latest//bin/java -server -DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath “/opt/openfire/lib/startup.jar” -jar "/opt/openfire/lib/startup.jar

and one more thing. I can use the jabber server fine (connect, see buddies etc.), I just can’'t use the UI