powered by Jive Software

Upgraded Openfire to 4.5.2 on CentOS 8 and now it's Inactive (dead)

Checked OS updates + Upgraded Openfire 4.5.1 -> 4.5.2. Now I have:

[00000@spark ~]$ sudo systemctl status openfire.service
● openfire.service - SYSV: Openfire is an XMPP server, which is a server that facilitates XML based communication, such as chat.

Loaded: loaded (/etc/rc.d/init.d/openfire; generated)

Active: inactive (dead) since Thu 2020-05-21 13:24:48 MSK; 46min ago

Docs: man:systemd-sysv-generator(8)

Process: 2143 ExecStop=/etc/rc.d/init.d/openfire stop (code=exited, status=0/SUCCESS)

Process: 2064 ExecStart=/etc/rc.d/init.d/openfire start (code=exited, status=0/SUCCESS)

Main PID: 2090 (code=exited, status=0/SUCCESS)

May 21 13:24:41 spark.city.local systemd[1]: Starting SYSV: Openfire is an XMPP server, which is a server that facilitates XML based communication, such as chat…

May 21 13:24:41 spark.city.local su[2078]: (to daemon) root on none

May 21 13:24:41 spark.city.local su[2078]: pam_unix(su:session): session opened for user daemon by (uid=0)

May 21 13:24:41 spark.city.local su[2078]: pam_unix(su:session): session closed for user daemon

May 21 13:24:41 spark.city.local openfire[2064]: Starting openfire:

May 21 13:24:42 spark.city.local systemd[1]: Started SYSV: Openfire is an XMPP server, which is a server that facilitates XML based communication, such as chat…

May 21 13:24:48 spark.city.local openfire[2143]: Shutting down openfire: [FAILED]

[00000@spark ~]$ sudo systemctl enable openfire.service

openfire.service is not a native service, redirecting to systemd-sysv-install.

Executing: /usr/lib/systemd/systemd-sysv-install enable openfire

All what I did is here:
[00000@spark ~]$ sudo yum install wget
Extra Packages for Enterprise Linux Modular 8 - x86_64 40 kB/s | 34 kB 00:00
Extra Packages for Enterprise Linux 8 - x86_64 29 kB/s | 26 kB 00:00
Extra Packages for Enterprise Linux 8 - x86_64 376 kB/s | 6.6 MB 00:18
PostgreSQL 12 for RHEL/CentOS 8 - x86_64 440 B/s | 3.8 kB 00:08
PostgreSQL 11 for RHEL/CentOS 8 - x86_64 3.6 kB/s | 3.8 kB 00:01
PostgreSQL 10 for RHEL/CentOS 8 - x86_64 12 kB/s | 3.8 kB 00:00
PostgreSQL 9.6 for RHEL/CentOS 8 - x86_64 11 kB/s | 3.8 kB 00:00
PostgreSQL 9.5 for RHEL/CentOS 8 - x86_64 13 kB/s | 3.8 kB 00:00
PostgreSQL 9.4 for RHEL/CentOS 8 - x86_64 4.9 kB/s | 3.8 kB 00:00
Package wget-1.19.5-8.el8_1.1.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[00000@spark ~]$ wget http://download.igniterealtime.org/openfire/openfire-4.5.2-1.x86_64.rpm
–2020-05-21 12:52:15-- http://download.igniterealtime.org/openfire/openfire-4.5.2-1.x86_64.rpm
Resolving download.igniterealtime.org (download.igniterealtime.org)… 52.58.216.59
Connecting to download.igniterealtime.org (download.igniterealtime.org)|52.58.216.59|:80… connected.
HTTP request sent, awaiting response… 302 Moved Temporarily
Location: https://github.com/igniterealtime/Openfire/releases/download/v4.5.2/openfire-4.5.2-1.x86_64.rpm [following]
–2020-05-21 12:52:16-- https://github.com/igniterealtime/Openfire/releases/download/v4.5.2/openfire-4.5.2-1.x86_64.rpm
Resolving github.com (github.com)… 140.82.118.4
Connecting to github.com (github.com)|140.82.118.4|:443… connected.
HTTP request sent, awaiting response… 302 Found
Location: https://github-production-release-asset-2e65be.s3.amazonaws.com/18511687/daa99380-9919-11ea-8136-b5576c25b08f?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20200521%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20200521T095217Z&X-Amz-Expires=300&X-Amz-Signature=0823c6f70dbae25aba88235e1c90a0f0c6c925bd469793ff04e9df7c0a61d308&X-Amz-SignedHeaders=host&actor_id=0&repo_id=18511687&response-content-disposition=attachment%3B%20filename%3Dopenfire-4.5.2-1.x86_64.rpm&response-content-type=application%2Foctet-stream [following]
–2020-05-21 12:52:17-- https://github-production-release-asset-2e65be.s3.amazonaws.com/18511687/daa99380-9919-11ea-8136-b5576c25b08f?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20200521%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20200521T095217Z&X-Amz-Expires=300&X-Amz-Signature=0823c6f70dbae25aba88235e1c90a0f0c6c925bd469793ff04e9df7c0a61d308&X-Amz-SignedHeaders=host&actor_id=0&repo_id=18511687&response-content-disposition=attachment%3B%20filename%3Dopenfire-4.5.2-1.x86_64.rpm&response-content-type=application%2Foctet-stream
Resolving github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)… 52.216.113.203
Connecting to github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)|52.216.113.203|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 128951978 (123M) [application/octet-stream]
Saving to: ‘openfire-4.5.2-1.x86_64.rpm’

openfire-4.5.2-1.x86_64.rpm 100%[==================================================================================>] 122.98M 11.3MB/s in 23s

2020-05-21 12:52:41 (5.27 MB/s) - ‘openfire-4.5.2-1.x86_64.rpm’ saved [128951978/128951978]

[00000@spark ~]$ sudo yum install openfire-4.5.2-1.x86_64.rpm -y
Last metadata expiration check: 0:05:18 ago on Thu 21 May 2020 12:48:18 PM MSK.
Dependencies resolved.
[=====================================================================================================================================================================>]
Package Architecture Version Repository Size
[=====================================================================================================================================================================>]
Upgrading:
openfire x86_64 4.5.2-1 @commandline 123 M

Transaction Summary
[=====================================================================================================================================================================>]
Upgrade 1 Package

Total size: 123 M
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing : 1/1
Upgrading : openfire-4.5.2-1.x86_64 1/2
Running scriptlet: openfire-4.5.2-1.x86_64 1/2
Restarting openfire (via systemctl): Warning: The unit file, source configuration file or drop-ins of openfire.service changed on disk. Run ‘systemctl daemon-reload’ to reload units.
[ OK ]

Running scriptlet: openfire-4.5.1-1.x86_64 2/2
Cleanup : openfire-4.5.1-1.x86_64 2/2
Verifying : openfire-4.5.2-1.x86_64 1/2
Verifying : openfire-4.5.1-1.x86_64 2/2

Upgraded:
openfire-4.5.2-1.x86_64

Complete!

Found in Openfire log this string:

org.postgresql.util.psqlexception the server requested password-based authentication, but no password is provided.