powered by Jive Software

Upgraded to 3.3.2 and lost Yahoo gateway

I upgraded my machine from Openfire 3.3.1 to 3.3.2 today and lost the ability for anyone to connect to yahoo. I’‘m currently running 1.1.0 b2 and it was working fine up until now. Excuse me since I’'m new to Openfire, but this seemed like the best place to ask.

at org.jivesoftware.openfire.gateway.protocols.yahoo.YahooSession$1.run(YahooSessi on.java:102)

2007.06.27 12:31:55 [org.jivesoftware.openfire.gateway.protocols.yahoo.YahooSession$1.run(YahooSess ion.java:145)

] Yahoo login caused IO exception:

java.io.InterruptedIOException: Login timed out

at org.openymsg.network.Session.login(Unknown Source)

at org.jivesoftware.openfire.gateway.protocols.yahoo.YahooSession$1.run(YahooSessi on.java:102)

This is what I can see in the log files. Sorry if this is common or known, but I couldn’'t find it in the forums.

Scott

Sorry, need to add more info. I lost the gateway with Spark (2.5.4). Pidgin seems to work just fine though. Haven’'t tried any other clients. And I am using the gateways in Pidgin, not connecting to the services directly.

Message was edited by: shutchi2

Unfortunately I’‘m not really sure what to tell you. I can’'t think of any reason why 3.3.1 vs 3.3.2 would matter.

Well, it gets even weirder, because I tested spark 2.5.4 on a few machines and they all lost Yahoo, but going back to 2.5.3 works just fine. It’‘s not a production machine, just my personal server at home, so I’'ll play with it some more.

Is it only Spark 2.5.4 that’'s seeing it at this point? (or rather not seeing it ;D )

Well, Spark 2.5.3 shows some Yahoo contacts, but not the whole list. My list is somewhat large (>100) so I’'m not sure if this is a problem with the gateway or Spark or the recent upgrade. It did work before the upgrade however.

I did just check Pidgin, however, and discovered the yahoo bug affects more than just spark. It appears that either the gateway or the server is at fault.

Looking back at your original post … do you keep seeing that error message that you posted? (login timed out) That indicates that Yahoo isn’‘t responding in any form of reasonable time frame or that something is in between (firewall? something) that is causing the packets not to get through. Of course this makes no sense what-so-ever as to why it worked before and doesn’‘t now. Just wanted to ask if you’'ve been seeing the messages still.

Do you use anything besides Yahoo?

Still seeing the error, and AIM/ICQ/MSN work just fine.

What happens if you use the connection tester from the admin console? Does it return success?

Yes, the connection tester works fine. I am able to connect, but I just see a few names from one group. My yahoo contacts list is larger and has multiple groups.

The error message you posted (login timed out) makes it seem like you weren’‘t able to connect in the first place. Interesting… Well I’‘m working on something that I think may have something to do with it so bear with me. =) I’'ll try to post a beta soon.

1.1.0 beta3 seems to have fixed the problem. Please let me know if you need any more info.

Thanks!

Awesome, thank you!