powered by Jive Software

Upgraded to Openfire 3.7.1, Spark "First Message Blank" Issue Remains


#1

As the title says, we’ve upgraded our server to Openfire 3.7.1 in the hopes that it would resolve our Spark issue of the first message someone receives from someone else is blank, but it did not.

I’ve seen several other users on this forum who have the same issue. This is turning into a show-stopper for us and I’m sad to say we’re starting to look into other server/client options.

Imagine if every quick, one-line message your users sent together simply popped up a blank box with no message in it. I don’t know if this is only an issue with the 2.6.3 Mac client, but this issue seems easily reproducable.

Anyone have any success fixing this?


#2

I have never heard about something like this. I am runnig more that 10000 clients on all kind of OSes. Can you be a little mor specific on your setup? This is OF 3.7.1 on LInus working against Mac Spark 2.6.3? Spark 2.5.8? Does it work on Spark 2.6.3 on Windows? Can you investigate the debug (available under advanced in the login screen)?


#3

We have same issue. We are piloting with 10 users, and it has affected all of them; average 2-3X per day/user - with the test users sending an average of 5 messages per day - that’s a 50% fail rate. Spark 2.6.3 on Win 7 SP 1 32 & 64 bit and Win XP SP 3. OpenFire 3.7.1 on Windows 2008 R2.


#4

Exact same problem here also, any solution for this so far?


#5

Similar problem here but it is limited to Spark client and the initial message rec’d via gateway


#6

Same problem here !!

First i used a OS X 10.6. Openfire Server and 2.6.3 Spark.

Now i’m using Windows 2008 Server for Openfire 4.0.1 and Spark 2.7.5 on OS X 10.9 clients, and still the same issue.

About 50 clients are actually in use and i get about 5 reports a day to this problem.


#7

Try the latest build http://bamboo.igniterealtime.org/browse/SPARK-NIGHTLYMAC-409/artifact/JOB1/Spark /spark_2_7_5_409.dmg


#8

Sometimes i can’t close the chatwindow.
It looks like the attachment and i have to restart Spark.

I found the following Message in the Spark Logs:

Mär 14, 2016 11:47:26 AM org.jivesoftware.spark.util.log.Log error

SCHWERWIEGEND: Error with IDLE status.

java.lang.NullPointerException

(SCHWERWIEGEND (German) = SERIOUS)

It appears every 10-30 seconds, maybe this is a note.


#9

Have you tried the newest build? This is the newest one http://bamboo.igniterealtime.org/browse/SPARK-NIGHTLYMAC-412/artifact/JOB1/Spark /spark_2_7_5_412.dmg


#10

Same Problem with this Version…

here are some interesting Logs from the Console.app in OS X:

In Picture 1 I recived an empty Message.

In Picture 2 I can’t close the Window.


#11

will you check you logs to see if you have something like

Unable to load private data for Gateways


#12

Can’t find something like that


#13

I’m using version 2.9.0 and am having this issue with every user the first time they talk to someone. Yes I know this is a night version and not a “proper version” but should not have this issue from years ago