powered by Jive Software

Upgrading to Open Archive 1.0.4 on Openfire 3.3.2

Hello all,

I have a Openfire 3.3.2 installed on Linux (Centos 4.4) and am using the Open Archive 1.0.3 plugin. Has anyone successfully upgraded from 1.0.3 to 1.0.4? I’ve tried deleting the plugin (using the webui) and then copying in the new archive.jar. All this results in is no Open Archive plugin being installed. I suspect it has something to do with a Permission Denied error in the logs (which have since disappeared)…

Any clues?

Cheers,

have you tried copying the jar archive into the plugins dir overwriting the old jar? (with a shell/ftp/scp - tool ) after a short time openfire should recognize the new jar and deploy it - that’s the way i update unofficial plugins, and it worked every time.

Hi all,

I finally found my problem… The plugin is not supported < 3.4.0. I’ll look into the upgrade path of openfire. I assume it’s as simple as shutting down the service and doing an rpm --update or something like that.

Cheers,