powered by Jive Software

User does not show up in contact list

User is logged into the chat server, can send IMs to others. User can get into chat room. His name is on the list of people currently in the chat room. However, his name is not on the contact list. This is true any time the user is logged into the chat server. User is using Spark as the IM client (but I believe we’ve seen this if he uses another client).

We’ve seen at least one other user with this problem, but he recently left the company.

Running Openfire Enterprise 3.4.1 (I know it’s not current. We’ve had this problem since before we upgraded to this version. I don’t see anything in the 3.4.5 release notes that suggest it is fixed there.)

Users authenticate into a Windows domain (Active Directory, Windows Server 2003). E.g., they’re not created manually in Openfire.

The “User properties” (in Openfire) for this particular user look like every other user, except that “Groups” says “none” instead of “JabberAccess”, which is the name of the security group in Active Directory we use to allow access to the chat server. I don’t have the option to edit the user in Openfire. I know the user account in Active Directory is right because the user wouldn’t be able to get into chat at all if he wasn’t a member of that security group.

How can I change the user’s group in Openfire away from “none”, or otherwise fix this problem?

Thanks,

Jim

Hello Jim,

Unfortunately I don’t have an answer for you yet, but do have a question for you, as I seem to be experiencing a similar if not the same issue with a similar setup (http://www.igniterealtime.org/community/thread/31280?tstart=0). Can you run a query on the AD server you are using for LDAP for the amount of members in your “JabberAccess” group? Can you then compare number of members listed there with the number of members Openfire shows on the admin console group summary page? Whenever I do this, it shows inaccurately.

I believe the one difference we may be experiencing is that when I pull up the “user properties” page of a user that is a member of the group in AD, but not showing in the “edit group” page (in the group summary section), it does indicate the group name that it should be in (but isn’t). Let me know your findings.