Username displayed in Spark instead of full name

We are in the process of rolling Openfire and Spark out in our Windows 7 environment. I am starting to notice that as users send each other invites they are showing up with a username instead of the full name in the Spark roster… Is there any way to administratively force the Spark “nickname” to always use the full name from Active Directory instead of the username? It seems to be somewhat random thus far. We’re using LDAP integration obviously.

Using Openfire 3.9.3 and Spark 2.6.3

I was able to resolve this by auto-populating groups of users by department. The groups were based on AD security groups and the configuration completed within the Users/Groups tab of the admin console. Open a group and utilize the “Enable contact list group sharing” & “Share group with additional users” feature rather than making all of your users invite each other.