powered by Jive Software

Users appears to log off and on in periods

Hi

I’m using OpenFire 3.6.2 on a Ubuntu Server 8.10 on vmware esx 3.5. I’m using Spark and Piding clients, but the problem appears on both.

The case is that I can see users logs off and then on back again right away. Sometimes it’s fine for days, and then suddenly out of nowhere, there is a period of maybey 10 or 30 minutes where a lot of users loggs off and on constantly. Suddenly it all stops and it’s fine until next time it goes crazy again. I have disabled compression.

Any ideas?

Anything in the errors log of Openfire and maybe Spark? I have seen such issue two years ago few times. I think it was related to some connectivity problems back then. And restart of the server solved this.

Hi and thank you for your reply. I logged for about 10 minutes now and I could see contacts logging on and off all the time. This is the only lines that comes over and over again in the error log:

2009.04.23 16:19:45 [org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSes sion(LocalOutgoingServerSession.java:258)] Error trying to connect to remote server: proxy.jabber.org(DNS lookup: proxy.jabber.org:5269)
java.net.UnknownHostException: proxy.jabber.org
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:519)
at org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSess ion(LocalOutgoingServerSession.java:253)
at org.jivesoftware.openfire.session.LocalOutgoingServerSession.authenticateDomain (LocalOutgoingServerSession.java:144)
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.sendPa cket(OutgoingSessionPromise.java:239)
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:216)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)
2009.04.23 16:20:23 [org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSes sion(LocalOutgoingServerSession.java:258)] Error trying to connect to remote server: jabber.org(DNS lookup: jabber.org:5269)
java.net.UnknownHostException: jabber.org
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:519)
at org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSess ion(LocalOutgoingServerSession.java:253)
at org.jivesoftware.openfire.session.LocalOutgoingServerSession.authenticateDomain (LocalOutgoingServerSession.java:185)
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.sendPa cket(OutgoingSessionPromise.java:239)
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:216)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)

I can’t see that is has anything to do with my problem, but I’m not sure. I’m starting to believe that there is something with the switch or the VMWare server, but on the other hand no other servers or applications has any problems.

Frode

Well. The only strange thing in your logs is that connection attempt to jabber.org. Have you enabled server to server connection? Check http://server:9090/server2server-settings.jsp

Is that the default settings? I can’t remember touching it. Anyway, it’s disabled now but I cannot imagine that id had anything to do with it.

Will see if a new period comes and post an update.

Frode

I’m not sure about the default settings for s2s. Logically would be to keep it disabled by default, but i dont have a machine to make a test clean install right now.

I believe it’s the default settings. Went to another server now and it was enabled by default. Both installations come from the defalt ubuntu repos.

My problems doesn’t appear all the time so I’ll give it a few days to see if something have happened.

Hi

I’m afraid the s2s-setting didn’t solve the problem.

Frode