powered by Jive Software

Users being removed from contact lists

I cannot figure out why my users are getting pop ups that say a user has removed them from there contact list, when the user really did not remove them from there list. I am running Jive 2.2.2 Server with Pandion 2.1.1 as the client. I am using the embedded database and there are approximately 30 users total that are set up withing 12 user groups. I have tried to remove the user and the group and then re add them and this will temporarily fix the problem, but it will eventually happen again. I did some searching online and someone says they had the same problem and that they went into the messenger.script file and changed the alert values for the users from 2 to -1. I dont really know what this means, but i did try to go into the messenger.script file and change all the 2 to -1 after the user names but luckily i made a backup of the messenger.script file cause that did not work. Any help on this would be greatly appriciated. dcorsaro@marcegaglia-usa.com

just a thought. You can try 2.3.0 release yesterday, maybe this issue has been fixed already.

I tried to upgrade to the 2.3.0 version of Jive, but still having the same problem with people getting removed. I dont know what else there is to try, so if anyone knows anything please advise. Thanks

Just to note, I am having the same issue also.

I just upgraded to Wildfire 2.4 yesterday (actually a clean install) and I’'m seeing this problem for the first time.

When anyone in the company (50+ employees) logs into the server with the Pandion client, they get a message saying that one particular user (always the same user) has removed them from their contact list. This happens every time they sign on, and the message always says the same user has removed them.

Any ideas?

I forgot to mention - I’‘m using LDAP for user account authentication, contact list population, and i’‘m also using LDAP groups for the shared groups that exist in everyone’'s contact list.

We’'re getting the same problem with version 2.4.4.

Everyone who uses Pandion on our server gets a message about the same 6 users having removed them everytime they sign-in. I’‘ve talked to one of those six people, and they haven’'t touched their contact list.

After a little more searching, it looks like some of those users have their status stuck as ‘‘online’’. Let me explain:

Three of the people who are mentioned in the alerts show up as online in Gaim. In Gossip, i get no alerts, but the people don’‘t show as online either. In Pandion, I get the alerts (saying that the user has removed me from their list) and they don’'t show up at all. If I try signing in as any of those people, I get a different list of people that have removed me. Help, please!

Message was edited by:

nosilver4u

I was having the same problem a while back and gave up on it. I figured out that it was people that were in a group and they were removed from the group or the group was removed and it screwed up something someplace. I had to finally remove all of the groups and then login with exodis and add the users back on each individual account. The log back in with Pandion and they were all there again. I have found it is best to not even use Pandion at all and use Spark. But there are so many features missing from it…

ItsNewToYou

That’'s not really an option, since we have over 300 users, and more than 20 groups.

Switching clients is feasible, but I don’‘t think that’'s really going to solve our problem, as it seems to be more of a database thing.

The fix ended up being this:

start a fresh database, and recreate all groups. Not fun.

Message was edited by:

nosilver4u

Very interesting.

In my opinion the database design was made by a poor database manager, so I still hope that it is redesigned. It’'s very sad that after a while such bugs can occur.

LG

The fix ended up being this:

start a fresh database, and recreate all groups. Not

fun.

Yeah. Have done this too. I’‘ve had other problems (people missing in rosters, though existing in Admin Console http://www.jivesoftware.org/community/thread.jspa?threadID=15765&tstart=0). I’'m making DB backup with userImportExport plugin. Though it didnt help me with that problem.

Well… we seem to be having the same problem now. We tested Pandion2.5 and Jive/Wildfire for 2 months with just 20 users and everything went OK. Now we’‘re slowly rolling out to about 50 users, before the big push to 700+, and we’‘re getting reports at the help desk of users getting popup messages that userx, usery…etc has removed you from their contacts list whenever they sign in. Sometimes it’‘s the same user name, other times it’'s almost totally random.

Using Wildfire2.4.3 and Pandion2.5, LDAP users list from AD and manually created groups. I there any fix other than blowing out Wildfire and recreating everything?

I’‘ve also recently noticed that some of our Microsoft AD names don’‘t work well under LDAP authentication, names with apostrophes and spaces don’‘t work, or need character codes to replace them with 9like %25 and %20 in the middle of their names or they can’‘t sign-in. Names like JO’'Doe for instance.

Bobby58

Did you edit your group alot? I mean deleting users from group and recreating groups again. I don’'t have the answer but your enviroment is similar to that of mine and I am interested in your case. I would be glad to know how things are going with your wildfire deployment.

Regards,

wmhtet

Hey guys,

If I’'m not wrong this same problem was discussed before and Pandion was being used too. The server will keep pushing a notification that a user has cancelled the subscription until the client sends an ACK to the server indicating that the notification was received. Try using Spark that will send the ACK and then continue using Pandion.

Regards,

– Gato

Yes, we have added and deleted groups as we where testing, also adding and deleting users from those manually created groups.

The problem is that many of the users indicated by these popup messages have NO client installed at all, never have and some of them never will. There is no way I can login as these users to try to get the acks out because we’'re authenticating against AD.

Should I just blow out our installation and start fresh every time this happens??

Bobby58

Which Database are you using (other than embedded Database)? Are you familiar with the database command? If so, try to take a look into the database to see if there are problems.Could you also please post error, warn, info, debug log over here so that we can take a look?

Regards,

wmhtet

We’‘re using the embedded database, running on Windows Server 2003. At the moment I don’‘t really know about the database commands. I’'ll do some reading.

Here are the only errors since the last time I flushed the logs:

THe error.log:

2006.02.22 08:51:19 [org.jivesoftware.wildfire.handler.IQRosterHandler.handleIQ(IQRosterHandler.jav a:118)

] Internal server error

java.lang.NullPointerException

at org.jivesoftware.wildfire.handler.IQRosterHandler.manageRoster(IQRosterHandler. java:172)

at org.jivesoftware.wildfire.handler.IQRosterHandler.handleIQ(IQRosterHandler.java :103)

at org.jivesoftware.wildfire.handler.IQHandler.process(IQHandler.java:48)

at org.jivesoftware.wildfire.IQRouter.handle(IQRouter.java:256)

at org.jivesoftware.wildfire.IQRouter.route(IQRouter.java:79)

at org.jivesoftware.wildfire.PacketRouter.route(PacketRouter.java:65)

at org.jivesoftware.wildfire.net.SocketReader.processIQ(SocketReader.java:395)

at org.jivesoftware.wildfire.net.ClientSocketReader.processIQ(ClientSocketReader.j ava:50)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:263)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

The warning.log: (this user is one of those causing daily problems with popup messages)

2006.02.22 08:51:19 Could not route packet

2006.03.01 15:26:49 Invalid presence type

java.lang.IllegalArgumentException: No enum const class org.xmpp.packet.Presence$Type.invisible

at java.lang.Enum.valueOf(Unknown Source)

at org.xmpp.packet.Presence$Type.valueOf(Presence.java:321)

at org.xmpp.packet.Presence.getType(Presence.java:106)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:216)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

I’‘ve had the debug log disabled, but next week I’'ll turn it back on (3 day weekend!

Bob

I’'ve been watching the debug log today and so far, this is the only error. There was some sort of null character beside the characters “vece” that I had to remove in order to copy and paste the error:

2006.03.06 13:54:05 Created context values, attempting to create context…

2006.03.06 13:54:05 Caught a naming exception when creating InitialContext

javax.naming.AuthenticationException: LDAP: error code 49 - 80090308: LdapErr: DSID-0C090334, comment: AcceptSecurityContext error, data 52e, vece

at com.sun.jndi.ldap.LdapCtx.mapErrorCode(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.processReturnCode(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.processReturnCode(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.connect(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.

2006.03.06 13:55:05 Creating a DirContext in LdapManager.getContext()…

after watching the debug log for a couple of days now, that error above is the only one and it occurs several times each and every day.

Same problem here. Using Pandion 2.5 and Wildfire 2.51.

It was not happening (we have over 100+ users with internal database running on Linux). It seemed to happen when we deleted a bunch of users (about 30) from groups that were blocked from using the server. It generated the following:

Everytime someone now logs in, only two users pop ups say that they have deleted you from the contact list. Havent figured it out and do not want to reconstruct the database…it is probably Pandion not sending ACKS back? If someone has solved this please post.

Thanks