Users can't message or see each other (but chat works fine)

I have a new install and have this odd issue. I have looked through the community and can’t seem to find anything that addresses it.

It is probably something really dumb that I am overlooking.

All users are on a local network. Users are regiseterd- I can see their sessions on the server.

Users can’t message each other. The sending user’s end acts normally, the message just doesn’t get to the other person.

On the buddy list (using Pidgin) they show “not authorized”.

However if the users enter a chat room, they can see and message each other.

Anyone have any ideas on this?



Well, have you tried to authorize them? In XMPP you can’t send a personal message to someone until you are authorized by him. O the other hand chat room is a public place, so anyone can send messages (except for some cases with more strict policies) and read messages in the room.

I suggest to check out the group sharing option. Create a group and check its settings, enable group sharing. This way you will get users authorized automatically.

That sounds like it may be the issue. Unfortunately we just left the office for the holiday. I will check it out next week and report back.


or check the rosters in openfire admin console

set the subscription to “both” on each user

Back at the office and on the project again. I’m going to try all these suggestions.

I reinstalled everything and then set up the users again.

This time I noticed the “authorize” requests. We acked them and everything works now. Thanks.