powered by Jive Software

Users Showing offline after upgrade

Hi, I did an upgrade on openfire to openfire 4.4.0 few days ago which was successful, then i encounter an error when adding users on the cllient “Spark” the users were all added but they kept showing as offline i have gone through the presence setting to see if the problem is from there, i also went ahead to upgrade spark to the latest version 2.8.3 but the problem persisted, please what can i do to rectify these issue.

Are you adding users manually and locally in Spark or via a shared group in Openfire? Also from what version have you upgraded? Btw, you can also upgrade to 4.4.1 while you at it.

I added users manually, don’t think there is a way to add users automatically though i can’t remember the last version i upgraded from.

I have just tried to create two new users on my Openfire 4.4.1 and add one of the to another user’s roster in Spark. Everything worked fine. I have received subscription popups and approved them on both sides and now they can see each other as online. You can check Openfire logs to see if any errors are logged there (openfire/logs/all.log)

I have just checked the log but there are no error found

Do you mean the log is empty? If not, post it say into https://pastebin.com/ and post a link here.

here is the link https://pastebin.com/beVG7AEJ

the above image shows all added contact as offline user, and the Muyiwa Teriba showing as been online is not seeing Victoria Uye online

I don’t see any hint in the logs. Other than an error with a certificate. Do you use a self signed certificate provided by Openfire. In Admin Console you can go to SSL/TLS certificates menu and press on a first Store link. It should show you your certificates. Maybe it will show some error.

here is the self assigned certificate, do i need to get another one

It looks ok, though it is strange that its start date is 08.07, probably when you have upgraded the server. So it has replaced your older certificate or maybe you didn’t have one before.

Your offline users have domain name attached to them. Usually they shouldn’t have that. When you add a user do you put only their username or do you also add the domain part? I think you shouldn’t add a domain part, as domain is already known to Spark when you login (you put it into Domain field on login screen).

Anyway, I don’t have ideas what is happening. If you have a backup, i suggest rolling back. Then you can maybe restore same backup on some test server and try upgrading and testing.

I think i will do a clean installation and see if it’s going to correct the issues maybe i made a mistake while configuring openfire during the upgrade.

You can also check Spark logs. C:\Users\User\AppData\Roaming\Spark\logs
There is a bunch of files, look through all of them and select events that correlate with the time of your issue.

It’s working fine now