Using an FQDN for my openfire server

I am a newbie to Web Server, talk about XMPP. I am learning this new concept using my personal laptop. I followed some tutorials online and copletely setup everything. I even tested using Spark and manual coding with Netbeans and Smack Library. Yesterday, I wanted to make my web server available on the internet, so I started looking for help. I found this SSL Guide from OpenFire documenation. de.html . I started with the Guide and followed everything completely. I have also created an FQDN from This was the domain I chose . When I visit the link, the browser says, the site is not trusted, since it has a self signed certificate. I ignore it, and advance, I find a login page. What is my Username and Password?

I messed up my keystore, so I wanted to start everything again. I un-installed OpenFire, deleetd the openFire database. Now, I would like to know how I can integrate my Domain Address (FQDN) as I set up this new one.

Thank you.

Actually this is not the Openfire login you are seeing there. It has an icon and looks like Fortinet Fortigate login page (we use that at work, so it looks familiar). Maybe you should login with your No-IP account there. Openfire’s admin console should be on 9090 or 9091 ports. But these ports are not available on your server.

Hi wroot,

Thanks for your reply. To be frank, I am using College Wifi. . I am in College and I live in College Hostel. We do have some sites which are blocked or filtered by Fortiguard Fortinet.

I have tried with no-ip username and password, I have tried with laptop username and password, email and password. Still I get authentication failure.

But if it is being filtered on my network, then it shouldn’t be a problem for you also.@wroot

No I don’t really expect this to be my openfire login. I was logging in at http://clinton-pc:9090/setup/index.jsp . Which means my host address was clinton-pc. But I saw a forum where they said to make your server available online, you need an FQDN. That is when this all happened. I was using my Admin Console peacefully until then.

Well, if Fortigate is blocking the access from outside to your pc running Openfire, then nothing can be done here. You need to open 9091 and 5222 ports on that router/firewall and forward them to your pc’s IP address.

Hi wroot,

Sorry for making this chat long and uninterested.

Will this issue be solved should I own my own router and configured it properly?

Also, the second part of my question was, how would I integrate my FQDN (if it was working) into my OpenFire installation?

Will this issue be solved should I own my own router and configured it properly?

Not if your connection would still be through your college’s network,which is blocking outside connections. Port opening and forwarding should be done by Fortigate administrators.

Also, the second part of my question was, how would I integrate my FQDN (if it was working) into my OpenFire installation?

You can try changing xmpp.domain system property to , but it might not work correctly. So it is probably better to rerun the setup and then set this as your server/domain name or start from the scratch with a new installation.

Just this last question .

So I don’t really need to touch my keystore and truststore files as this guide de.html says? If it doesn’t apply to my case, then what is SSL and LDAP as used by OpenFire in their documentation and how will they be applicable to me?

So I would use my FQDN in this stage of my setup right? Openfire-Setup-Server-Settings-200x109.png

Consider this as you the teacher, me the student. Thanks for your patience.

I haven’t used that guide. I’m using self-signed certificates which are generated and applied in Openfire’s web based console (Admin Console).

SSL is the secured (encrypted) connection. It is safer to use SSL than just a plain connection. You can use the self-signed certificate which Openfire produces or import one issued for you by some authority. LDAP is the lightweight directory access protocol, it is used to integrate Openfire with LDAP (Microsoft AD or other) to pull the users from.

Yes. You would put you FQDN in to Domain field.

Hi wroot,

I have gotten access to a router. I logged in and tried portforwarding, following some guideline with my “public ip”. This was giving me an error that :

Error code: 26106
The IP address is not in the same subnet with LAN IP address.

Since this error, I chose a static ip for myself on the network and used that ip address instead of my public ip address. It began to work correctly. But the problem now is, I can only communicate with server if I am using the same network (Wifi in this case) and not otherwise. Do you have any suggestions for me? @wroot

Thank you.

I haven’t done actual port forwarding on a router, so can’t tell how exactly this should work. Also, different routers probably do this differently. Maybe you should ask ones who administrate your network how to do it properly. In theory, you define a port in router’s configuration and tie a local LAN address to it. So when a connection from the Internet hits your public IP with a port number (you defined before), your router forwards such connection to the selected local IP address, which is listening on that port. In this case that would be 5222 TCP port. Standard port on which XMPP servers listen for client connections.