Using spark client on workstations NOT associated to domain

Good afternoon. I’ve been looking around on and off for a few days on this so I apologize ahead of time for not finding an existing post on this.

I have recently installed the latest openfire server and spark combo where I work. We have it working fine on about 15 machines without issues. It runs on a windows 2008 R2 server attached to our domain, we’ll call it company.local domain. All workstations that are joined to the same domain work fine.

I’m trying to get the service working at another one of our locations. These workstations are NOT on the same domain. There is a trust between the domain and workstations can resolve DNS by adding the company.local to any server they want to resolve. When I install the spark client and enter in what I think is the right set of information to authenticate spark it fails the authentication process. There are no entries in the logs for me to even guess at what the issue is.

The workstation can ping the openfire server by name and by IP. I have tried many different ways to log in such as:





I have tried entering in the server name multiple ways as well:


If there is documentation specific to this scenario I can read I’m happy to do so if pointed in the right direction. If anyone has some hints I’m all ears. Maybe this isn’t even possible using clients not on the same domain?

EDIT: These locations are bridged by a branch to branch VPN passing traffic through the tunnel unrestricted. All tunnel traffic between specified subnets are not blocked by any rules.

Thank you!

You can try putting the IP in the Advanced settings on the login screen (Host) and then just the server name in the Server field.