powered by Jive Software

Very Slow Server - Can't connect - HELP

Some days ago, I’ve got an expressive slowdown on my server connection time.

If a try to acess my localhost:9090 I can’t connect to it in order to time out connection.

I’ve got an 8 GB memory server but it’s fast in the first 30 minutes, after it I can’t connect to it.

Already changed openfire archive in line INSTALL4J_ADD_VM_PARAMS and got no results.

Using a Mysql data bank

Can anyone save me ???

Tx

Hi Antonio,

read JVM Settings and Debugging and enable at least the GC log. When things tend to get slow you should look at the gc log and make sure that the garbage collections are not the reason for the slowdown.

You may even want to take some stacktraces / javacores and monitor the whole server. Is it idle or busy when Openfire gets slow?

LG

Hi LG

I did add some strings on openfire file ( INSTALL4J_ADD_VM_PARAMS="-Xms32m -Xmx2048m -Xss128k -Xoss128k -XX:ThreadStackSize=128 -XX:+HeapDumpOnOutOfMemoryError -Djava.net.preferIPv4Stack=true" )

I has worked for 4 days with 1% of memory usage. Since yesterday it has become to slowdown again . Like 99% of memory usage.

My server is 90% of hardisk space usage FREE and I got a 2GB ram server

Don’t know what to do !!

Tx for your help

Hi Antonio,

did you read the memory announcement:

Openfires up to and including version 3.6.4 suffer from a memory leak in its PEP component. If your Openfire domain is crashing with OutOfMemoryExceptions, you might be having this problem.

As a workaround, you can disable PEP, by setting the Openfire property xmpp.pep.enabled to false.

More information can be found in this discussion: Openfire 3.6.4 memory leak with Empathy

Maybe it help. In any case you should enable the gc log which shows the memory usage and the time for gcs. With 1% memory usage you should be able to set Xmx to 100 MB or less.

LG

What does PEP mean ?? My server is in Portuguese - Brazil and I figure out it might be written in another way.

looking deeply in Openfire Properties, there’s no xmpp.pep.enable line in it

=[

Tx anyway

Hi Antonio,

please scroll down and add this property, then it will be there.

LG

lol …

fuckin me … lol

Tx again LG