powered by Jive Software

Web-based client (jwchat?) with wildfire

Ok ive looked at about 50 sites, both on this forum and elsewhere on the internet, and I can not get JWChat to work with wildfire. I dont really care which web client I use or how I do the http-polling…I just need a way that works. All of the “tutorials” are either jabberd based, linux based, or I just couldnt get them to work.

I am running wildfire 2.4.2 and Windows 2000.

I have installed Apache and Tomcat.

I am currently trying to use JabberHTTPBind and JWChat but either one or both of these can be changed.

Please do not reply to this with a redirection to a thread that is already around, I have read it and it didnt help me. Thank you in advance.

Hi Zeleznikja

For me it is realatively easy to set up tomcat and jwchat. I am not a very experienced user and I also needs help in the beginning for minor things but other than that everything goes smoothly.

I only use tomcat. I put the jwchat war file into tomcat “webapps” folder, then stop and restart tomcat. tomcat will extract .war file into a folder.

/apache-tomcat-5.5.12/webapps/jwchat-1.0beta2

If you have not configured tomcat, you are going to access the webpage as follow

For default Tomcat page

http://localhost:8080

For Jwchat

http://localhost:8080/jwchat-1.0beta2/

You can check out the following link to configure your tomcat also.

http://www.jivesoftware.org/community/thread.jspa?threadID=17403&tstart=15

I have tried to install tomcat and wildfire on three different machine: Linux and windows XP at work and Windows XP at home.

For linux everything goes smoothly, but for windows at work, SSL setting does not work ( I still can’‘t figure out why). for Windows at home, I can’‘t even start tomcat. The reason, I think is that the network enviroment in my home windows is not correct (I don’'t have time to look into it yet, I have it working before and I install too many applications and some change the network settings).

So please try again to install them a dedicated clean box and it should be fine.

regards,

wmhtet

Hey Jason,

It’‘s been awhile since the last time I used JWChat with Wildfire (or better say Jive Messenger since that was the name of the server during those days). Maybe you want to tell us the steps that you are doing and the problem that you are having so we can try to replicate them and see what’'s going on.

Thanks,

– Gato

I just uninstalled apache, tomcat and jwchat.

I then…

installed apache

installed tomcat

placed the jwchat-1.0beta2.war into the webapps directory (which it then automatically unpacked)

When I then go to host:8080/jwchat-1.0beta2 I see the welcome screen.

If I login it just opens a window and it looks like everything is fine.

However it does not actually log in. If I check the log viewer for wildfire it gives a “connection closed before session established”

Keep in mind I have ONLY done what it says above, no config files where changed.

If I have the server as “local host” it throws the above mentioned message.

If I have the server as “test-xmpp-win” it seems to connect fine.

If I have the server as “test-xmpp-win.disa.mil” it opens a window but the window freezes.

Anyways I think I might be good for now…thanks wmhtet, what you told me to do was excatly what I was looking for…simple and works.

How come all the other threads and pages make this seem difficult, having to add like 100 lines of code to 4-5 different files?

So I do not need apache installed at all then?

mhhh

i have no problem with jwchat and wildfire

i grabbed the war file from the jwchat sourceforge page and deployed it with the tomtcat manager.

tomcat 5.5.12

sun jdk 1.5.0 U5

linux: centos4

wildfire 2.4.2 with hsqldb

browser mozilla 1.7.12

Hi

If you know what you are doing, you can use apache as well. But for simple purpose tomcat just work fine. I think that you are reading the threads which tried to customized tomcat and jwchat, or if you are talking about thread for other server, it might well be true that you need to do much work. But with wildfire, it is very simple. Glad that my advice has been useful to you.

Regards,

wmhtet

we were able to get it to work through our SecurID server, but it kept booting users, so we had to abandon it because we couldn’'t get any help to fix it.

Jason

Jason

I think, it is more to do with the SecureID server and its setting. If you can tell us how it works, may be we can think of a way to make it works.

Regards,

wmhtet

Has anyone successfully implemented jwchat with Wildfire on Win XP with Tomcat? The server works, I access the welcome/log-in screen but can get no further.

I’'d appreciate directions towards a light weight web or executable client that can easily be downloaded by users.

Thanks.

Hi,

as this is a java application it does not matter if you are using windows or linux as long as you are using SUN’‘s JVM. I’'ve got it running on XP and linux.

Did you use jwchat.war and did you modify the config.js inside jwchat.war?

LG

I downloaded jwchat-1.0beta2.zip, unzipped it to jwchat and placed jabberhttpbind’'s WEB-INF AND META-INF folders in a directory JHB: webapps/JHB/…

I modified the config.js.

I access my local machine via http://marklee.dyndns.org:8080/jwchat

Thanks.

Registering an acct here works: http://marklee.dyndns.org:9090/plugins/registration/sign-up.jsp

Message was edited by: starapple

Could you share some info on the config.js file? I’'m wondering whether my problem has to do with the defaultconferenceserver setting.

I also placed the JabberHTTPbind in the Tomcat server but have no idea if this is in any way connected with the functioning of jwchat.

RGDS.

Hi Mark,

did you set up a DNS record for conference.jabber.org or only for jabber.org? (Replace jabber.org with your jabber hostname.)

LG

var SITENAME = “jabber.org”;

var DEFAULTCONFERENCESERVER = “conference.jabber.org”;

Hello LG,

OK; here I am again TGIF. Both vars are set. I can’'t seem to find documentation on using jwchat except whith what appears to be building with Apache.

Thanks.

Mark

BTW, do I have to add the port number? eg server.org:5222

Message was edited by: starapple

Hi Mark,

are you sure that you did set up JHB the right way? If you can’‘t answer the question with yes then please do yourself a favor and use the jwchat.war file and edit it’'s config.js file.

Did you read http://jwchat.sourceforge.net/support.shtml ? There you may learn how to fix some JWChat issues like searching.

LG

LG

I did edit the config.js.

Everything works fine locally when the vars are set to LOCALHOST. It’'s when I attempt to log in via http://marklee.dyndns.org:8080/chat that the problems crop up.

Mark.

Hi Mark,

is JHB trying to connect to marklee.dyndns.org:5222 and there it hits a firewall?

Maybe you can edit your hosts file (/etc/hosts for unix, %windir%\system32\drivers\etc\hosts for windows) and add a line:127.0.0.1 marklee.dyndns.orgto solve this problem.

LG