powered by Jive Software

Webadmin reverts to setup: Please Help!

Something really strange just happened. I just tried to log into my openfire webadmin page and it is bringing up the setup page! The server has been up and running for a few months now. I haven’t changed anything on the server since the last time I logged in… I’ve restarted the server several times to no avail. The odd thing is the server is running fine and my spark clients are still connecting. If I try to run through the setup is get hung on the database selecting. I’m using the embedded database. Please help!

Look at you openfire.xml file and verify all the settings look correct then check to make sure the " <setup>true</setup>" is not set to false.

everything looks ok.

<?xml version=“1.0” encoding=“UTF-8”?>

<!–

This file stores bootstrap properties needed by Openfire.

Property names must be in the format: “prop.name.is.blah=value”

That will be stored as:

<prop>

<name>

<is>

<blah>value</blah>

</is>

</name>

</prop>

Most properties are stored in the Openfire database. A

property viewer and editor is included in the admin console.

–>

<!-- root element, all properties must be under this element -->

<jive>

<adminConsole>

<!-- Disable either port by setting the value to -1 -->

<port>9090</port>

<securePort>9091</securePort>

</adminConsole>

<admin>

<!-- Use this section to define users that will have admin privileges. Below,

you will find two ways to specify which users are admins. Admins will

have access to the admin console (only local users) and may have also access

to other functionalities like ad-hoc commands. -->

<!-- By default, only the user with the username “admin” can login

to the admin console. Alternatively, you can specify a comma-delimitted

list usernames that should be authorized to login to the admin console

by setting the <authorizedUsernames> field below. -->

<!-- <authorizedUsernames></authorizedUsernames> -->

<!-- Comma-delimitted list of bare JIDs. The JIDs may belong to local

or remote users. -->

<!-- <authorizedJIDs></authorizedJIDs> -->

</admin>

<locale>en</locale>

<!-- Network settings. By default, Openfire will bind to all network interfaces.

Alternatively, you can specify a specific network interfaces that the server

will listen on. For example, 127.0.0.1. This setting is generally only useful

on multi-homed servers. -->

<!–

<network>

<interface></interface>

</network>

–>

<connectionProvider>

<className>org.jivesoftware.database.EmbeddedConnectionProvider</class Name>

</connectionProvider>

<setup>true</setup>

<log>

<debug>

<enabled>false</enabled>

</debug>

</log>

</jive>

If you are running the server as a service, check to make sure that the process isn’t running twice. We had the same problem on a server running fedora linux after a power outtage and found that the service was starting twice.

up… that got it. thanks!