powered by Jive Software

Webchat + Fastpath + Openfire 3.7.1 Finally working

Dear all,

After almoust 1 month i finnaly managed to get webchat+fastpath+openfire 3.7.1 working.

I use this configuration on my company webside, we have almoust 40.000 consultants that use our customer services webchat.

Since version 3.6.4 webchat stoped to beeing developed, but someone who i cant recall his name has coded a version that works with openfire 3.7.0.

For me and my company was mandatory that webchat plugin work with this new openfire versions, Fastpah and Openfire always worked fine but theres no web interface and i need it.

So i’ve managed an work arround with this config, just to let you know and if someone wants i can do some movie showing how i´ve done.

What i have used:

Openfire 3.7.1


Webchat.war (wornking 3.7.0 version)

MySql 5.5.1

Java J2SE 5.0 update 22

Tomcat 7.0.22

Installed MySQL and created DB openfire, installed openfire 3.7.1 using MySql DB + plugins (fastpath + webchat)

Installed Tomcat with webchat plugin, so webchat insted of run on broken openfire webserver run on tomcat but for that i needed to change some ports.

If someone needs help on similar configuration im more than glad to help


1 Like

Great you have it working finally

Installed MySQL and created DB openfire, installed openfire 3.7.1 using MySql DB + plugins (fastpath + webchat)
Probably you meant only fastpath plugin here as you later install webchat into Tomcat. Or do you install it twice? I wasn’t aware it doesnt work with the Openfire webserver (Jetty). I thought i have read it works for someone with that recompiled webchat.war (btw, the link http://community.igniterealtime.org/thread/44193)

Also, you have marked this thread as a question, but probably you don’t really want any answers here. So you can mark it as answered

Hi wroot,

Probablly i did not need to install it twice but just for be sure i did

The webchat.war that i had used was that one you told, and i always had problems with it (on openfire 3.7.1)

I always get error 504 and 400 (i guess) with Jetty.

Thanks for your help.

So, you used something else rather than webchat?

i’m sorry, maybe i’m not reading this right, when you say webchat you mean the fastpath webchat is that right? (no experience with fastpath at all here, getting ready for the first trial)

I’d like to setup fastpath on 3.7.1 and like everyone else i’m having issues. i havent done much with webchat but i will have to use it alot now for a site. lucklly i have a virtual machine to test stuff on.



Hi Rodrigo,

I dont know if you have / want a configuration similar to mine.

But on my openfire server i have installed Fastpah and Webchat, i use web chat on my webpage for customer services support. So i need both options Fastpath and webchat!

Fastpath runs well on Openfire 3.7.1 the problem is webchat… i dont know what but i could never get jetty to work so i installed tomcat web server and run webchat there.

I you want i could do some walktrought for you… this is if you want some config like mine

Fastpath for support for managed queued chat requests, such as a support team might use and webchat Web based chat client for Fastpath for my webpage.

Im IT manager at a big cosmetics company and we have more than 40.000 consultants so as you can imagine webchat for supporting them is more than helpfull

Hi, i would really like to get some pointers on how to setup an environment like the one you’ve discribed

Sorry for the delay, family member passed away and things have just backloged. Hopefully i’ll be up to speed soon.

I’ll be starting a tiny (really tiny) setup to help with family bussines and this is one of the things i can see i’ll need it, in fact, fastpath is one of the reasons why i choose openfire over other xmpp servers.



I you want i could do some walktrought for you… this is if you want some config like mine


That would be great. It would be greatly appreciated.


Hi Pedro,

I just installed Openfire 3.7.1 + Fastpath + Webchat on Suse Linux server. I could access Admin Login screen on the Suse linux machine. But when I tried to access http://myserver:9090 from another machine on the same intranet, I couldn’t connect to the server. Any idea what could be wrong?



Firewall, mis-configured network, DNS problems? You’ll probably want to start with the basics (telnet to port 9090 on that server from something else and see what it does). Most likely not an Openfire issue though.

Hi David,

Thank you for your reply!

It was the firewall. After I opened additioinal ports, I was able to connect. I used Suse Linux Enterprise Sever (SLES).

  1. Stop firewall – /sbin/rcSuSEfirewall2 stop

  2. Edit /etc/sysconfig/SuSEfirewall2.

#FW_SERVICES_EXT_TCP=“80 mysql smtp ssh”

FW_SERVICES_EXT_TCP=“80 mysql smtp ssh 9090”

  1. Start firewall – /sbin/rcSuSEfirewall2 start

I really appreciated your help!


Oh hey, could you please tell us what to do to get the webchat frontend to work with OF 3.7.1? The service plugin is running fine but if i’m trying to install the webchat i get an error:

2012.03.05 16:48:08 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: C:\Openfire\plugins\webchat
java.lang.NoClassDefFoundError: org/mortbay/jetty/servlet/Context
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
at java.lang.Class.getConstructor0(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)

I also mentioned it over here.

I’m running a tomcat 7 server so it would be great if you could share your webchat.war you’re using on your tomcat.


@rene-1 Please try the webchat.war given herein.

How to make it work when XMPP host is different from XMPP domain? I found that isn’t working in this version