Webchat not found 404


I’ve got a new install of Openfire running on ubuntu server. Everything’s going great execpt webchat for fastpath.

I’ve tried installing the plugin from the admin console, but it doesn’t even appear in the plugins list after installation.

I found this board and tried this: http://community.igniterealtime.org/docs/DOC-2156

Still get a 404 on :7070/webchat

Tried webchat.war from this: http://community.igniterealtime.org/thread/44193?tstart=0

Same problem, no joy. No instructions on how to use webchat-4.0.2-openfire-3.7.0.patch.zip, so I tried uploading it as a plugin. That didn’t do anything.

At least now I’m getting a “Tools” link and the plugin appears to be installed. But I still can’t access the webchat config. Tools link gives me the same 404 error:


Problem accessing /webchat. Reason:

Not Found

Powered by Jetty://

Can someone provide some guidance on how to make this work?

Well I figured it out, sorta.

Ran into some other unrelated problems and found out my architecture was faulty. Was using openfire on an old Mac Pro PPC, and I couldn’t get the Sun java packages to work. I had tried an open alternative, but that seemed a bit buggy.

I switched to an intel based PC, and voila, everything’s running perfectly.

Weird that Sun wouldn’t target the Ubuntu on PowerPC market, eh? (kidding)