Webchat showing no icons

I have tried to set up Wildfire Ent. with Fastpath connecting to Active Directory. To get Wildfire to work I had to change the nameField part in wildfire.xml to:


to be able to log in. So my thoughts go, can this have anything to do with my problems with webchat?

Here is the debug when I go to /webchat with a web browser:

2006.10.30 11:15:07 Trying to find a user’'s DN based on their username. sAMAccountName: 8c32cc72, Base DN: OU=Ansatte;DC=it-akademiet;DC=corp…

2006.10.30 11:15:07 Creating a DirContext in LdapManager.getContext()…

2006.10.30 11:15:07 Created hashtable with context values, attempting to create context…

2006.10.30 11:15:07 … context created successfully, returning.

2006.10.30 11:15:07 Starting LDAP search…

2006.10.30 11:15:07 … search finished

2006.10.30 11:15:07 User DN based on username ‘‘8c32cc72’’ not found.

2006.10.30 11:15:07 Exception thrown when searching for userDN based on username ‘‘8c32cc72’’

org.jivesoftware.wildfire.user.UserNotFoundException: Username 8c32cc72 not found

at org.jivesoftware.wildfire.ldap.LdapManager.findUserDN(LdapManager.java:613)

at org.jivesoftware.wildfire.ldap.LdapManager.findUserDN(LdapManager.java:541)

at org.jivesoftware.wildfire.ldap.LdapUserProvider.loadUser(LdapUserProvider.java: 77)

at org.jivesoftware.wildfire.user.UserManager.getUser(UserManager.java:186)

at org.jivesoftware.wildfire.user.UserManager.isRegisteredUser(UserManager.java:30 9)

at org.jivesoftware.wildfire.SessionManager.getBestRoute(SessionManager.java:889)

at org.jivesoftware.wildfire.net.SocketPacketWriteHandler.process(SocketPacketWrit eHandler.java:74)

at org.jivesoftware.wildfire.spi.PacketDelivererImpl.deliver(PacketDelivererImpl.j ava:48)

at org.jivesoftware.wildfire.handler.IQHandler.process(IQHandler.java:50)

at org.jivesoftware.wildfire.IQRouter.handle(IQRouter.java:268)

at org.jivesoftware.wildfire.IQRouter.route(IQRouter.java:96)

at org.jivesoftware.wildfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:67)

at org.jivesoftware.wildfire.net.SocketReader.processIQ(SocketReader.java:250)

at org.jivesoftware.wildfire.net.ClientSocketReader.processIQ(ClientSocketReader.j ava:51)

at org.jivesoftware.wildfire.net.SocketReader.process(SocketReader.java:216)

at org.jivesoftware.wildfire.net.BlockingReadingMode.readStream(BlockingReadingMod e.java:156)

at org.jivesoftware.wildfire.net.BlockingReadingMode.run(BlockingReadingMode.java: 62)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:123)

at java.lang.Thread.run(Unknown Source)

Ok, furthermore, I can tell you I made a chat group and I am online with the spark client. Everything in that manner seems to work, just not the actual webchat part. Also, I did the anonymous user plus the everyone can create chatrooms. I can actually see my support group chat room is created.

Please help!

I have now tried to set it up with just a local database, without Active Directory, and that works fine.

Seems this is an AD problem.

Would love to get this problem solved. We are evaluating a solution for our web page, and to be able to support xmpp clients for our students would be a great bonus

Ok, I set it up again, and again, and on the third time it just worked. Go figure.