powered by Jive Software

Websocket WSS not working

I tried to get Openfire running on our server. So far so good.

When I try to connect, I got already almost every error-message available. Now, I need help, I’m stuck.

Here are some details:
Due to restrictions for new users in this board I have to reformat the domains like domainXcom.
We’re running an own server on Ubuntu 16.04, Java 1.8.0_162 64Bit, OpenFire 4.2.3
Server Hostname (FQDN) is domainXcom
Servername is domainXcom

Trying to connect with strophe.js to
wss://intranetXdomainXcom:5223 (Encrypted (legacy-mode) connections)

We prefer Websocket-Connections and the Port must be 5223 due to firewall-restrictions.
Usernames are like "user@domainXcom"
Server runs on "domainXcom"
Chatplattform runs on “intranetXdomainXcom”

Working with http-bind worked perfect.

For SSL we use an Alpha SSL Cert (*XdomainXcom), valid untill dec 2018. At Server -> TLS/SSL Certificates there is a notice like “One ore more certs are missing”

While connecting, I get the error “WebSocket opening handshake was canceled”

Currently Openfire’s listening to
5222 C2S
5223 C2S
5263 CM
9090
9091
7777 FT Proxy
5229 Flash CD

Everything else is disabled

Any ideas?

Thank you!

Use wss://intranetXdomainXcom:522/ws/ in strophe