WF 3.1 -> AD SecurityContext Error


I read several posts here and quite a few tutorials but I’'m kind of lost.

I try to get 3.1 running on Gentoo to work with an AD on an Win2003 Server.

Whenever I try to connect (via hitting the test button in the graphical setup of Wildfire) I get

“Error authenticating with the LDAP server. Check supplied credentials.” My WF-logs are terribly empty and so are the ones on Windows. So I installed Wireshark to check what the buggers are doing and I got this reply from my Windows:

LDAPMessage bindResponse(1) invalidCredentials (80090308: LdapErr: DSID-0C090334, comment: AcceptSecurityContext error, data 525, vece)

I’‘m an absolute newbie when it comes to LDAP/AD, so probably I’'ve overseen something.

The AD is a fresh and basic install…do I need any special plugins to make that work?

WF-Config-Frontend looks like:

BaseDN: “dc=test;dc=nbw;dc=lan”

AdministratorDN: “cn=admin;cn=users;dc=test;dc=nbw;dc=lan”

PW: ****

I also tried several other AdminDNs, as everyone seems to say something else…


I also tried Users and Buildin (just in case)

My AD is called test.nbw.lan, my User is admin@test.nbw.lan.

If you need more input, tell me.

Another problem:

In the last step of the setup, the Wildfire asks me to add more priviledged users. Adding works fine, but how do I finish the setup? How do I get out of the “Add more people” page to save the setup?

Thank you for any help, it’‘s probably simple but I can’'t figure it out by myself.

Strange effect…I searched for 2 days for a solution and as soon as I post it here…a friend of mine read through it and the problem was solved via phone within 10 minutes…my apologies for bothering you, the first part of my Problem is solved…I used the “Logon name” as CN, but you have to use the Username (wich I thought is not for Logon). So, as assumed, a newbie to LDAP Problem. It might be nice to put a hind on your tutorial, so others don’'t stumble over such simple problems.

The second problem however remains: I cannot finish the setup wizard.


I solved the second problem as well:

For some reason the wildfire.xml was write protected, thus adding users resulted in an error in “error.log”.

The Webinterface did not say anything and just dropped me back to “Add a user”.

It might be good to have a basic checkup at the start of the Setup that checks if all files are at their right place and all priviledges are set correctly. As such errors are quite annoying, but easy to spot for the program itself.

Message was edited by: No.2 - Added solution to problem.

Solution was added to last post in thread