powered by Jive Software

What am I missing? Cannot connect to Openfire

Hi I tried to get Openfire running from the instructions at http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/install- guide.html#config

Hi, I ran the rpm package on my CentOS 5.8 server at 199.19.95.52 and started Openfire with /etc/init.d/openfire start . No errors so far. I also installed MySQL ready for use when I can get in. That all seemed to go well. Now I try http://199.19.95.52:9090 to access the remote server and there is no response.

What else do I need to do to get this to work? Do I need to install apache first or is that all handled by the RPM package?

Please help this newbie get started. :slight_smile:

Michael

Since raising the ticket I also installed java runtime environment which wasn’t there before. So I get:

]# java -version

java version “1.7.0_25”

OpenJDK Runtime Environment (rhel-2.3.10.5.el5_9-x86_64)

OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

But I’m still missing something, because the browser doesn’t doesn’t retrieve anything.

Michael

When I disable the firewall I could make progress. But now it asks for the server IP. Should I leave it as 127.0.0.1 or use the actual external IP address of the server? Or should I use the external hostname e.g. chat.vhelplive.com ?

hello. you may want to refrain from posting your IP address and/or URL of your server, as this is a public forum and there may be people observing that can be up to no good.

Anyways, most of the time, you are OK to just use the defaults when setting it up. I used your posted IP address and was able to get a login screen, so I"m assuming it’s running ok now?

Hi, well I got in and could log in. I have yet to connect properly to it via SparkWeb. What I am not sure about is whether I should be using my external IP address, or 127.0.0.1 or a hostname to set this thing up right.

internally openfire will likely refer to itself using the loopback (127.0.0.1 address). For your external clients (Spark and Spark-Web), they will need to enter your server’s public address (IP address or URL) in order to point to the right server.

So if your openfire is running on your network, it likely has an ip address on that network. lets just says it’s 192.168.0.10

In your openfire config, it would need it’s loopback 127.0.0.1 so it can talk to itself. Spark and Spark-Web clicents need to enter 192.168.0.10 to communicate with the server over the network.

If you’re trying to do public access outside your network, you would need to open some ports on your network’s firewall and allow traffic to your server. then external public clients would put in your public ip address at your office/home or the URL you assigned it.

Hope that helps.