powered by Jive Software

What's the proper way to set up openfire on a subdomain (what am I missing)?

I’m running my openfire server on a subdomain – call it chatserver.example.com – but I want my users to be able to log in as user@example.com, and I want other jabber users to be able to add myuser@example.com to their rosters.

Easy, right? I’ve set up my SRV records:

_xmpp-server._tcp.example.com. 3600 IN SRV 0 0 5269 chatserver.example.com.

_xmpp-client._tcp.example.com. 3600 IN SRV 0 0 5222 chatserver.example.com.

Now, if I leave my xmpp.domain setting to chatserver.example.com, then I can log on as user@chatserver.example.com, and add another jabber user, say, example@gmail.com, and the request goes through.

If I change xmpp.domain to example.com, though, I can log in to the openfire server as user@example.com, but no subscription requests come in or go out… the logs show this:

2009.05.19 00:19:58 Error returning error to sender. Original packet:

org.jivesoftware.openfire.PacketException: Cannot route packet of type IQ or Presence to bare JID:





at org.jivesoftware.openfire.spi.RoutingTableImpl.routePacket(RoutingTableImpl.jav a:217)
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.return ErrorToSender(OutgoingSessionPromise.java:285)
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:219)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)

What do I need to change so that server to server works?

That all sounds correct. Not sure why server to server wouldn’t work because of this setting. What version of Openfire on what OS?

Openfire 3.6.2 on Ubuntu Gutsy.

Any ideas about the error that’s being reported?

Ah! The problem was that we had google chat set up for our domain – and that was interfering with the dialback.

Disabling it and waiting a few hours seems to have fixed it.