powered by Jive Software

When Integrating OF with MS LYNC; Server Dialback fails "<db:result from="xyz.bsg" to="abc.com" type="invalid"/>"

Hi OF Team,

We have OF running on linux box(Centos) in our Firm, This OF is AD authenticated. Now, recently we have build Microsoft’s LYNC in our network. I am trying to federate/integrate OF with LYNC but, it is not working.

I would be highly thanful to you, if you can go through the below logs captured from LYNC and OF and suggest me the best possible to way acheive this integration.

Logs Captured From LYNC

TL_VERBOSE(TF_PROTOCOL)[0]0E78.0BF4::12/20/2012-08:25:04.939.00002a16 (OCSXMPPGateway,StreamLogger.LogBlock:4.idx(3436))(0000000000F440EB )

---------- Outbound10.15.248.31:5269 ----> 10.10.1.107:45235 ----------

<db:verifyfrom=“techmahindra.com” id="8c68d897"to="techm.bsg"type=“valid”>8d998e4249b7e1994f78cad9a8f38847c04bccd 1</db:verify>


TL_INFO(TF_COMPONENT)[0]0E78.0BF4::12/20/2012-08:25:04.939.00002a19(OCSXMPPGatew ay,IncomingTcpDialbackSecProvider.FirstStream:13.idx(759))(00000000008197AF )Dialback key authorized to techm.bsg: 10.10.1.107

TL_INFO(TF_COMPONENT)[0]0E78.0BF4::12/20/2012-08:25:04.939.00002a1c(OCSXMPPGatew ay,SocketLayer.AcceptReceiveCallback:33.idx(287))(000000000235EB26 )New incoming connection from 10.10.1.107

TL_VERBOSE(TF_PROTOCOL)[0]0E78.0BF4::12/20/2012-08:25:04.970.00002a1f(OCSXMPPGat eway,StreamLogger.LogBlock:4.idx(3436))( 0000000000F440EB )

---------- Inbound10.15.248.31:5269 <---- 10.10.1.107:45235 ----------

</stream:stream>


TL_VERBOSE(TF_PROTOCOL)[2]0E78.0C84::12/20/2012-08:25:04.970.00002a21(OCSXMPPGat eway,StreamLogger.LogBlock:4.idx(3436))( 0000000002CD6BF9 )

---------- Inbound10.15.248.31:58792 <---- 10.10.1.107:5269 ----------

<db:resultfrom=“techm.bsg” to=“techmahindra.comtype=“invalid”/>

Logs Captured From OF**
**

2012.12.20 13:47:40 org.jivesoftware.openfire.net.BlockingAcceptingMode - Connect Socket[addr=/10.15.248.31,port=58772,localport=5269]

2012.12.20 13:47:40 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: AS - Verifying key for host: techmahindra.com id: 3f610486

2012.12.20 13:47:40 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: AS - Key was: VALID for host: techmahindra.com id: 3f610486

2012.12.20 13:47:40 org.jivesoftware.openfire.net.BlockingReadingMode - Logging off techm.bsg/c8874a8c on org.jivesoftware.openfire.net.SocketConnection@1657d4 socket: Socket[addr=/10.15.248.31,port=58772,localport=5269] session: org.jivesoftware.openfire.session.LocalIncomingServerSession@123db8a status: 1 address: techm.bsg/c8874a8c id: c8874a8c

2012.12.20 13:47:40 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: OS - Validation GRANTED from: techmahindra.com id: 3f610486 for domain: techm.bsg

2012.12.20 13:47:40 org.jivesoftware.openfire.session.LocalOutgoingServerSession - LocalOutgoingServerSession: OS - SERVER DIALBACK XMPP 1.0 with techmahindra.com was successful

2012.12.20 13:47:40 org.jivesoftware.openfire.net.BlockingAcceptingMode - Connect Socket[addr=/10.15.248.31,port=58773,localport=5269]

2012.12.20 13:47:41 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: RS - Received dialback key from host: techmahindra.com to: techm.bsg

2012.12.20 13:47:41 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: RS - Trying to connect to Authoritative Server: techmahindra.com(DNS lookup: sinnodxmppg.techmahindra.com:5269)

2012.12.20 13:47:41 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: RS - Connection to AS: techmahindra.com successful

2012.12.20 13:47:41 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: RS - Asking AS to verify dialback key for idfea55274

2012.12.20 13:47:41 org.jivesoftware.openfire.server.ServerDialback - ServerDialback:** db:verify answer was: <stream:features xmlns:stream=“http://etherx.jabber.org/streams”></stream:features>**

2012.12.20 13:47:41 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: RS - Closing connection to Authoritative Server: techmahindra.com

2012.12.20 13:47:41 org.jivesoftware.openfire.server.ServerDialback - ServerDialback: RS - Sending key verification result to OS: techmahindra.com

2012.12.20 13:47:41 org.jivesoftware.openfire.net.BlockingReadingMode - Logging off techm.bsg/fea55274 on org.jivesoftware.openfire.net.SocketConnection@1367d10 socket: Socket[addr=/10.15.248.31,port=58773,localport=5269] session: org.jivesoftware.openfire.session.LocalIncomingServerSession@175d06d status: -1 address: techm.bsg/fea55274 id: fea55274

2012.12.20 13:47:57 org.apache.mina.filter.executor.ExecutorFilter - Launching thread for /10.5.5.79:1695

Further, I have attached the PNG files which gives an infromation about settings used.

PLEASE HELP

Thanks & Regards,

Adhiraju Mouli


1 Like

We are OK for paying additional cost incurded for customizing the Openfire Code. Please can you here …

Hi ALL,

As i am an getting benefitted out of this great Opensource tool, hence i had thought of giving back some of my findings back to the forum (OPENFIRE).

FYI, i finally solved the above error by making some changes in source code. And found that now (after change) this error got resolved.

If you are facing the same error, then i can help you around here.

With Regards,

Mouli A H V K

Please consider attaching a patch against subversion trunk and we can perhaps get it included.

We had the same problem. TCP dialback problem, between Lync and Openfire.

I posted in the forum asking to log more information in the debug file, because we need to analyze the network traffic to detect this tcp dialback failure.

Link to post: http://community.igniterealtime.org/message/231396#231396

After that, we did the source code modification, to resolve this problem. We detect that there is a network message out of the order that Openfire is expecting. Our question is, if is the lynk that sends a message out of oreder, or is Openbfire that can handle correctly with this message.

Link to post: http://community.igniterealtime.org/message/231666#231666