powered by Jive Software

Wildfire 2.6.1 compatiblity issues

Earlier I read that Wildfire 2.6 has compatibility issues with MySQL 4, particularly with MySQL 4.0 authentication.

I am running Wildfire 2.5, and would like to upgrade, but I don’'t want to break anything. I have a SuSE Linux Enterprise 9 production server, so compatibility is important.

Does 2.6.1 work with MySQL 4.0.18, or does it require MySQL 4.1 and higher?

Hi Sunad,

where did you read about authentication issues?

2.6.2 is the current version and it should be fine for all databases while 2.6.1 may cause trouble. You will hit this problem as Wifi updates from the database changes from one version to another like 2.5->2.5.1->2.6->2.6.1->2.6.2 but not for every version the database did change.

So you may create another database user, maybe “bunny” and import the wifi 2.5 schema there. In the table jiveversion you will find the current version, maybe 4 or 5. If you download and look at Wifi 2.6.2 (.zip or .gz version) you’‘ll find “/database/upgrade/N” directories. You could run the (v5 if needed - I think 2.5.0 has version 5 so it’'d not be needed,) v6 manually. The v7 will fail, so you should not run v7 and v8.

v7 and v8 update could be replaced by the “Create-Pubsub” lines (7 tables) found in /database/wildfire_mysql.sql and “INSERT INTO jiveVersion (name, version) VALUES (’‘wildfire’’, 8);commit;”

I hope you are able to upgrade the “bunny” schema manually without problems, so also the jive schema should not be a problem.

LG