Wildfire 2.6.2 <> Pandion 2.5 File tranfer problem

Hello, tho I’‘ve seen many posts regarding this issue, I haven’‘t been able to find a solution for my problem in any of those threads. I’‘m running a WiFi 2.6.2 server on Windows XP Pro (I’‘ve set it up on my home PC just for test purposes) and everything is working just fine, except for one thing, the file transfer beetween clients… Now, all clients are using Pandion 2.5 and I have tried sending files with and without firewalls running at both clients and even on the server side to no avail. I’‘m not using a domain so I son’‘t have a DNS, instead I’'m using IP address for all users to connect e.g. yz7rea@ etc. The following params are in place in my system properties:


xmpp.proxy.enabled true


xmpp.proxy.port 7777[/b]

However the file transfer is still not functioning… Can someone please give me a hand?

Thank you in advance!

Vladimir - YZ7REA

Pandion tranfer files peer to peer, he is not use file transfer proxy…

All pandion clients must to be ‘‘visible’’ between his, to be place in same network etc…

sory 4 my bad english

Is this a bug in Pandion? Or in the spec is a MAY that a client use the proxy for file transfers?

Not sure, but one thing is certain. File transfer DID work with this same HW configuration, same server/client SW versions before. I had to reinstall my OS (with the same OS CD FYI) and after that I couldn’'t make file transfer work… Any ideas?

What happens if you install pandion on a base XP install with no AV and firewall disabled?

Reason why I ask is that I am wondering if your AV has a firewall in it that disables the XP firewall and that’‘s what’'s causing your problems…

It could also be something else that’'s affect it, hence the question about a fresh install with nothing…

Well, it’‘s a bit late for that LOL but I have disabled the currently active Firewall (BlackICE) completely… My AV is NOD32 2.50 and as far as I know it doesn’‘t have a buil-in firewall. On the other hand XP’‘s built-in FW has been manualy disabled since the OS installation, so I don’'t see what else could be blocking the transfer…


Hi again… After talking to Pandion developers on another forum I have indeed confirmed that Pandion uses Peer-to-Peer connection between clients to send files… I am looking for a way to instruct Pandion NOT to use PtP and switch to WiFi’'s file transfer proxy @ port 7777 instead…

Thanks for your replies,


First i’'d like to thank reaxer for giving us a good solution.

but reaxer’'s is a little confusing.

i’'ve successfully solved the problem on my pc and server.

the only file you have to modify is src/file_send.html.

you don’'t have to change file_recv.html.

how to modify src/file_send.html? here we go:

find: external.HTTPEngine.subscribe( external.wnd );[/color]

below this line, add:

external.HTTPEngine.SetProxyInfo( ‘‘yourhost’’, port, ‘’’’, ‘’’’ );[/color]

example: external.HTTPEngine.SetProxyInfo( ‘‘google.com’’, 7777, ‘’’’, ‘’’’ );[/color]

hope you enjoy it.

conclusion:[/b] pandion doesn’'t need a proxy server to receive file, but when sending file, a proxy server is necessary.