[Wildfire 3.1] Update from Beta 1 to Beta 2

Hi @all,

i tried to Update Wildfire Beta 1 to Beta 2 on a Linux Server with the RPM Build without success:


schnipp -


rpm -Uvh wildfire_3_1_0_beta_2.rpm

Preparing… ###########################################

package wildfire-3.1.0-1 is already installed

file /opt/wildfire/.install4j/user.jar from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/README.html from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/changelog.html from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/documentation/index.html from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/lib/hsqldb.jar.pack from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/lib/startup.jar from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/lib/wildfire.jar.pack from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/plugins/admin/webapp/WEB-INF/lib/admin-jsp.jar from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/plugins/admin/webapp/style/global.css from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/plugins/search.jar from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_cs_CZ.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_de.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_en.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_es.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_fr.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_nl.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_pl_PL.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_pt_BR.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1

file /opt/wildfire/resources/i18n/wildfire_i18n_zh_CN.properties from install of wildfire-3.1.0-1 conflicts with file from package wildfire-3.1.0-1


schnapp -


Any Suggestions for me, how to Upgrade?

Hrm. What does:

rpm -qa | grep wildfire

Say? It almost sounds like you have multiple wildfire rpms installed.

Same error for me

  1. rpm -qa | grep wildfire

wildfire-3.1.0-1

I believe I recall this being a problem with the way the RPM was created, but I’'m not certain. I typically have to rpm -ev the old one and -then- add the new one. Alternatively, you can do rpm --force -Uvh … to force it to ignore the conflicts.

OK, i have done it with the --force switch. It works, but i had to made a new initial Configuration when i call the admin console. Thank Goodness he didn’'t overwrite the database so that all informations from the old install are available.

Thanks for help