Wildfire 3.2.0 installation issue on Windows NT 4.0 SP6a

Installation Wildfire of version 3.2.0 interrupts, leaving in a log file such message

Could not display the GUI. This application needs access to an X Server.

If you have access there is probably an X library missing.


You can also run this application in console mode without

access to an X server by passing the argument -c


An error occurred:

java.lang.UnsatisfiedLinkError: C:\TEMP\e4j18.tmp_dir19181\jre\bin\awt.dll: ?? ??? ??? ???

Error log: C:\TEMP\install4jError25119.log

Contents install4jError25119.log are lower

Exception:

java.lang.UnsatisfiedLinkError: C:\TEMP\e4j18.tmp_dir19181\jre\bin\awt.dll: ?? ??? ??? ???

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(Unknown Source)

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)

at sun.security.action.LoadLibraryAction.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at sun.awt.NativeLibLoader.loadLibraries(Unknown Source)

at sun.awt.DebugHelper.(Unknown Source)

at java.awt.Component.(Unknown Source)

at com.install4j.runtime.installer.Installer.getScreenExecutor(Unknown Source)

at com.install4j.runtime.installer.Installer.main(Unknown Source)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

System properties:

java.runtime.name=Java™ SE Runtime Environment

exe4j.moduleName=S:\Install\Servers\Jabber\wildfire_3_2_0.exe

exe4j.semaphoreName=s:_install_servers_jabber_wildfire_3_2_0.exe

sun.boot.library.path=c:\temp\e4j18.tmp_dir19181\jre\bin

java.vm.version=1.6.0-b105

java.vm.vendor=Sun Microsystems Inc.

java.vendor.url=http://java.sun.com/

exe4j.consoleCodepage=cp0

path.separator=;

java.vm.name=Java HotSpot™ Client VM

file.encoding.pkg=sun.io

user.country=RU

sun.os.patch.level=Service Pack 6

install4j.exeDir=S:\Install\Servers\Jabber\

java.vm.specification.name=Java Virtual Machine Specification

user.dir=C:\TEMP\e4j18.tmp_dir19181

java.runtime.version=1.6.0-b105

java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment

java.endorsed.dirs=c:\temp\e4j18.tmp_dir19181\jre\lib\endorsed

os.arch=x86

java.io.tmpdir=C:\TEMP\

line.separator=

java.vm.specification.vendor=Sun Microsystems Inc.

user.variant=

exe4j.tempDir=C:\TEMP\e4j18.tmp_dir19181

os.name=Windows NT

sun.java2d.noddraw=true

sun.jnu.encoding=Cp1251

java.library.path=S:\Install\Servers\Jabber;.;C:\WINNT\Sun\Java\bin;C:\WINNT\Sys tem32;C:\WINNT;C:\WINNT\system32;C:\WINNT;C:\ARC;c:\temp\e4j18.tmp_dir19181\jre\ bin

java.specification.name=Java Platform API Specification

java.class.version=50.0

sun.management.compiler=HotSpot Client Compiler

exe4j.isInstall4j=true

os.version=4.0

user.home=D:???\michail

user.timezone=Asia/Yekaterinburg

java.awt.printerjob=sun.awt.windows.WPrinterJob

file.encoding=Cp1251

java.specification.version=1.6

java.class.path=C:\TEMP\e4j18.tmp_dir19181\i4jruntime.jar;C:\TEMP\e4j18.tmp_dir1 9181\user.jar;C:\TEMP\e4j18.tmp_dir19181\platform.zip;

user.name=michail

java.vm.specification.version=1.0

java.home=c:\temp\e4j18.tmp_dir19181\jre

sun.arch.data.model=32

exe4j.launchName=S:\Install\Servers\Jabber\wildfire_3_2_0.exe

user.language=ru

java.specification.vendor=Sun Microsystems Inc.

awt.toolkit=sun.awt.windows.WToolkit

java.vm.info=mixed mode

exe4j.unextractedPosition=17446416

java.version=1.6.0

java.ext.dirs=c:\temp\e4j18.tmp_dir19181\jre\lib\ext;C:\WINNT\Sun\Java\lib\ext

sun.boot.class.path=c:\temp\e4j18.tmp_dir19181\jre\lib\resources.jar;c:\temp\e4j 18.tmp_dir19181\jre\lib\rt.jar;c:\temp\e4j18.tmp_dir19181\jre\lib\sunrsasign.jar ;c:\temp\e4j18.tmp_dir19181\jre\lib\jsse.jar;c:\temp\e4j18.tmp_dir19181\jre\lib\ jce.jar;c:\temp\e4j18.tmp_dir19181\jre\lib\charsets.jar;c:\temp\e4j18.tmp_dir191 81\jre\classes

install4j.appDir=C:\TEMP\

java.vendor=Sun Microsystems Inc.

file.separator=\

java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi

sun.io.unicode.encoding=UnicodeLittle

sun.cpu.endian=little

sun.desktop=windows

sun.cpu.isalist=pentium_prommx pentium_pro pentiummmx pentium i486 i386 i86

Previous version 3.1.1 was install and worked normally.

This is exactly the same problem I had - I even tried installing Jave SE 1.6 directly and that also failed to install.

I had previously installed 3.1.1 with no problems.

I’‘m beginning to consider installing W2K as an interim solution (I’'ve been told 3.2.0 installs fine) until I can install new servers and move over to CentOS.

Martyn

Martyn wrote:

This is exactly the same problem I had - I even tried installing Jave SE 1.6 directly and that also failed to install.

Please wrote to SUN bug tracker and give me link.

I not very strong in english for it.

Message was edited by: NT Man

Hey Martyn and NTman

I am using NT4 sp6 too, as you know Martyn thank’'s for your previous hellp )and I know from own experince that you are able to install Java 1.5.6 as the most on NT4. Too bad, I know, and Wildfire 3.2.0 is only running with Java 1.6 and that is the reason for the interruption at install. Happened to me too.

And I just have reinstalled my production server (NT4) a week ago, and that server is not only running wildfire…

turbo

turbo, Martyn and all NT OS user I offer leave comments here

NTman,

what is that and can I use my forum Log-in credentials ?

Let me know.

turbo

Hi,

JM-939 is the issue to change Wildfire that one can complie it with JRE 1.6. It makes no sense to add comments there as the issue is fixed. You can anyhow create there a JIRA account, then you are able to vote for issues and can leave comments.

Wildfire 3.2.0 runs fine with JRE 1.5.0 - some of the beta builds did run only with JRE 1.6.0.

Extracting wildfire_3_2_0.zip and starting it should work if you have JRE 1.5 installed, even on NT.

My index.jsp displays:

Version: Wildfire Enterprise 3.2.0

JVM Version and Vendor: 1.5.0_06 Sun Microsystems Inc. – Java HotSpot™ Server VM

OS / Hardware: Windows XP / x86

LG

Hi NT Man,

Sun does not support Windows NT so it makes no sense to try to open a bug there. It may be time for you to update your server either to a current Linux version or to Windows 2003.

LG

it2000 wrote:

Hi NT Man,

Sun does not support Windows NT so it makes no sense to try to open a bug there. It may be time for you to update your server either to a current Linux version or to Windows 2003.

LG

Thanks, it2000

  1. I try ask to sun, increase list supported operating systems…

  2. I try ask dombiak gaston for support JRE 1.5.0…

Hi LG,

as I am really interesting to run 3.2 still on NT, how would I go onto the upgrade using the zip file as my 3.1.1 is running fine.

Did you go that route and what were the steps ? I don’'t want to mess with my current working Wildfire.

turbo

Hi turbo,

I did a fresh “installation” by just extracting the zip file to c:\tmp.

Do you have a spare NT server where you can do the same? If you don’'t have one then you must shutdown Wildfire before you continue.

Start c:\tmp\wildfire\bin\wildfire.exe - this is fine to do basic tests, then run the setup process and select the embedded database (will be stored in c:\tmp\wildfire\embedded-db), so you will not modify your existing installation in any way. If you are using plugins download a new version of them as the plugin API did change. A few plugins are - as far as I know - not yet compatible with Wildfire 3.2.0.

If this works fine then we may think about migrating your existing installation.

LG

Hi NTman,

as I did post above Wildfire 3.2.0 runs fine using JRE 1.5 on Windows XP, so I assume it does this also on Windows NT.

LG

Hi LG,

will work on that. I have a spare install on a different machine. If this is working,how would the migrating be ? I am using the build-in database, no plugins so far, but noticed in a few post that those should be downloaded again and installed.

The installation with the install.exe doesn’‘t work, as it seems to try to install the new 1.6 Java and that is the culprit as on NT only 1.5.6 (if I am correct) is the furthests one can install. But your’'s ist showing 1.5…for the Java

turbo

Hi,

there’'s the wiki / sticky thread in this forum but the document looks very complicated … so you may want to migrate this way:

Shutdown Wildfire

Make a backup of your wildfire folder.

Make a backup of your database (unless you are using the embedded one).

Make an extra backup of wildfire.xml.

Extract wildfire.zip so it overwrites the existing wildfire folder and the files in it.

Restore wildfire.xml. (The zip archive does not contain a database, so an existing embedded database will not be overwritten)

Start Wildfire

Check the log files.

LG

thank you LG.

Will let you know tomorrow after test. I hope I can

turbo

Hi LG,

as I had installed the 3.1.1 with the installer I had the java enviroment folder jre in the wildfire dir which I didn’'t delete.

The steps I did after all of the backups:

  1. extracted the 3.2.0 into a directory of my choice.

  2. copied the files over, actually folder by folder.

  3. I started wildfire and got the message that the Java_Home enviroment is missing. I thought to overcome this error by leaving the jre directory (created from the 3.1.1. installer)in place.

I tried without any luck to set the enviroment JAVA_HOME to D:\wildfire\jre\bin\server or even D:\wildfire\jre\bin

as I don’'t have java directly installed by other means.

And my index.jsp shows as well

JVM Version and Vendor: 1.5.0_08 Sun Microsystems Inc. – Java HotSpot™ Server VM

If I translate the error message correct, I have to set this variable, but how ? Any helpful tips would be very appreciate.

Thank you

turbo

Hi turbo,

I don’'t know how Wildfire searches the JRE.

Maybe it helps if you copy it to %programfiles%\Java\ - so you should have java.exe here: %programfiles%\Java\jre1.5.0_06\bin\java.exe

Can you install JDK 1.5.0_11 or any other 1.5 version (JDK, not JRE as the JRE usually does not contain a “server” JRE) on Windows NT or does this fail?

LG

Hi LG,

I can install jdk 1.5.0 had done this, but at that time didn’'t know about the Java_Home seetings and scrapped the whole thing. With a fresh download of the 3.1.1. installer I got it finally just fine installed.

So, I could install jdk 1.5.0. What’'s your idea ? Installing jdk , and go from there ?

Let me know.

turbo

My request to Sun:

Hi, Roger,

It is impossible to increase list supported operating systems? Wanted see in list Windows NT 4.0

Answer from Sun:

Hi Mike,

Due to the end of life cycle of Windows NT(according to Microsoft), I’‘m afraid we are not able to add NT as a supported platform for Java 5 and Java 6 at this time. However, I would suggest you to post this idea on our forum for discussion. If there are a lot of users’’ concerns regarding this, we can consider that. Last but not least, Java 1.4.2 still supports Windows NT.

turbo, Martyn and all NT OS user I offer come to Sun discussion forums for discuss idea increase list supported operating systems .

Message was edited by: NT Man

Hi turbo,

if you can install the JDK then you should indeed try this. And then extract Wildfire_3.2.0.zip and try to run it.

LG